Files already on OneDrive appear as "Not allowed"

So I’ve switched from OneDrive sync client to Odrive because I had a lot of problems with OneDrive sync client on Mac… But now I’m having this issue, I haven’t found anyone with the same issue, similar, but not the same…
I know OneDrive doesn’t allow some characters in names, but these files are already in my OneDrive, and are not being downloaded because “the file’s already there”…
so I let it slide, empty the trash and then when I go to my OneDrive, those files have been deleted, then I restore them and get the same error repeating the process again…
this is clearly a Odrive sync client issue, something to do with foreign characters… And, as you can see in the 2nd screenshot, it has no problem with other characters like #, because inside that same folder I have other files that are successfully being synced…

Hi @JoeX92,
This may be incorrect error handling for an exception coming back from OneDrive.

Can you send a diagnostic from the odrive tray menu so that I can take a closer look? This will also create a file in the root of the odrive folder named “current_odrive_status.txt” that will have some details in it. Can you attach that here, as well, or PM it to me?

ok, I generated the diagnostic file: current_odrive_status.txt (515.3 KB)

I tried to check the diagnostic file out and decided to look up for 1 of the file as “not allowed”. and found out that the files are there but not being synced…
So let me explain what I did prior to migrate to odrive:

  1. I just closed my onedrive sync client and set it up to not open at login, then
  2. I open odrive client wait for the synced clouds to appear and make odrive download the “cloud” files on my onedrive cloud (only the parent ones),
  3. close odrive,
  4. move the files I already had downloaded from my onedrive sync client’s folder to the odrive’s onedrive folder,
  5. deleted the “cloud” files that I already had downloaded and
  6. finally opening odrive…

the client did pretty much great, recognized all the files already downloaded and synced them to onedrive, but, now I realize, the problem comes with those specific files with foreigns characters, for some reason it doesn’t sync them and just tells me that they are already in onedrive, So I decided to, now, see what happens if:

  1. I take out 1 file that was already downloaded but not synced
  2. recover the “cloud” file from the bin (because for some reason it sent the cloud files from those files to the bin, that’s why when emptying the bin would delete the files from the cloud), and 01
  3. make odrive download the file

And it worked! but that was 1 file, so basically I have to do it manually what odrive already could do with the rest of the files? that is weird, because I found some other files that had foreign characters too but were synced successfully…

I’ll send 2 diagnostic files, one before what i did (at the top) and other after what i did, here’s the second one: current_odrive_status.txt (519.4 KB)

Hi @JoeX92,
Thanks for the additional information.

In this case odrive had an issue reconciling these particular files with their remote counterparts, although I’m not sure why. The method you tested was what I was going to suggest, for the time being, until we can figure out why these particular files were not seen as equivalent.

Essentially odrive saw the deleted placeholders and has those queued for remote delete. It also sees the physical files and thinks they need to be uploaded. Usually this will result in a no-op, where these two will cancel out, but odrive isn’t seeing them as equivalent, for some reason. It may be something specific with the characters, although, as you noted, odrive is able to deal with unicode characters without issue in most cases.

Can you provide me with one or two of the files that are having issues so I can test with them?

oh I see, thanks for being so supportive, It’s a first for me for some dev actually trying to solve a problem right away, that’s one of the problem I had at Microsoft with OneDrive support
Anyways, here’s a screenshot of the folder I’m going to share with you:
I chose this folder so you can see there 2 of the files that have the issue and other ones with the same kind of characters are not having the issue…
Here’s the link to the OneDrive folder
[I was trying to upload the exact same files here, but mp3 files aren’t allowed… Should be fine to test, because those files are suppose to be the same, haven’t made any change to them…]

anyways, I was thinking that it maybe has something to do with the unicode of the characters…? I mean, each one of the characters, in the Japanese language in this case, should have a unicode in some order and maybe there’s a problem with a group of characters because of their unicode, maybe because it gets confused by other character because the sequence of the unicode is similar, idk, just trying to make sense of it… anyways, hope you can solve the issue…

I will leave this folder without syncing manually just to test if in some update it gets resolved and post that it was resolved… :slight_smile:

Thanks @JoeX92. I am going to try to dig into this today.

Hey @JoeX92,
I just wanted to let you know I haven’t forgotten about this.

Unfortunately I haven’t been able to reproduce the same effect that you are seeing on the couple of Macs that I have been testing.

Here are the steps I am taking:

  1. Initially upload a problematic file
  2. Unsync the file to convert it into a placeholder
  3. Delete the placeholder and wait for odrive to process the delete so that it shows up in the odrive trash
  4. Copy the problematic file back into the same location

At this point I was hoping to see what you saw where the file will get stuck in “not allowed”. Instead I am seeing our expected behavior where the file is marked as synced and the corresponding item in the odrive trash is removed.

I also followed your initial example above, where you exited odrive, added the file and deleted the placeholder, and then started odrive again. This also resulted in the file being considered synced.

Is there anything else I should be trying to reproduce what you are seeing?

Are you able to reproduce this where you can explicitly trigger the issue happening again?

Additionally, can you try the following steps to see if the issue remains or goes away for one of these files?

  1. Move one of the problem files out of odrive to a temp location
  2. Restore that file’s placeholder from the odrive trash
  3. Move the physical file (from step #1) back into the folder, alongside the placeholder file

The expected behavior is that odrive will remove the placeholder and consider the file now synced locally.

thanks for the follow up, I did what you asked and still got the same issue, here’s the diagnostic file: current_odrive_status.txt (730.5 KB)

Did you do exactly the same as me? sync the problematic file with OneDrive client and then the rest with odrive? because I’m guessing it might has something to do with what the onedrive client do with synced files, i don’t know, just guessing… maybe the hash checking? idk…

Finally I decided to reinstall odrive client, just in case I wasn’t using the latest release, and the same issue, here’s the diagnostic file: current_odrive_status.txt (377 Bytes) so I decided to just do it manually, it’s just 1 folder left… in the end this was just a “one time” situation, because, untill microsoft fixes their onedrive client (I’m guessing never), I’ll keep using odrive, and I have the plus to sync other clouds, so is still a win for me…

Anyways… technically the issue is not resolved persé but is acknowledge and I’m thankful for that… now that I think about it, I’m using High Sierra, not Mojave neither Catalina, because I use some softwares that are stable in this version, on a mid2012 macbook pro, so idk if that would have something to do with it… It would be good to know if this got resolved somehow… i don’t know, maybe it even had to do with what other apps I use in the background, like a fan monitor, daemon tools, little snitch (which I set to always bypass any connection from odrive), istatistica, or maybe I should reset onedrive client even though is not open, just in case I’ll try that… either way, thank you… it’s good to know that there are apps with good support… :slight_smile:

1 Like

Thanks for the follow-up @JoeX92!

I actually didn’t try an upload from the Mac OneDrive desktop client, so I will give that a shot on my next go-around.

The most important thing is that you’ve gotten it sorted out so its not an issue for you. I am still going to poke at it to see if I can identify where there might be an issue. If I can find a reproducible scenario then we should be able to fix it.

1 Like