File uploads stuck midway, syncing to google drive

I’m not sure what happened, but I have a bunch of video files (100mb - 10gb in size) and they no longer successfully upload to my google drive. When I hover over “Syncing Changes”, they will partially upload then get stuck at a certain percentage for hours. I have a bandwidth monitor application that shows that odrive is sending several GB of data per hour, but the percentage remains stuck. I’ve tried restarting my computer so other files start uploading first but the same issue continues to happen.

Hi @an1645a ,
Can you send a diagnostic from the odrive tray menu and I’ll take a closer look at what is happening here.

You are observing that data is being uploaded, but the percentage is not moving and the upload never finishes, correct?

Just let me know when you are able to send over the diagnostic.

Sorry for the late reply, I was initially receiving an error when sending over the diagnostic but I finally got the notification that the diagnostic was able to send.

Since making the OP, I uninstalled then reinstalled odrive and left my computer on overnight to see if that would improve anything, but the same problem persists. It seems like a good portion if not majority of my files since November haven’t successfully uploaded to my google drive. Not sure why that is but now that I’ve noticed this there are hundreds of files that are on the waiting list.

Hi @an1645a ,
You must be hitting an error during upload that odrive is attempting to automatically retry, but those retries are not successful. Can you exit the current version and install this test version, when you get a chance ?

This version will log some extra information in the sync activity log. Once you start seeing items that appear to be stuck uploading, please generate another diagnostic and send me the sync activity log, so I can take a look. You can get to the log from the odrive tray menu under “Syncing changes” → “Open Sync Activity Log”.

I sent over the diagnostic. I was looking through the log and I see the following over and over again:

INFO A Google Drive upload fault was detected. Attempting to retry. Exception: (‘The write operation timed out’,)

I’m also seeing a lot of my folders are being ignored during the local scan because they are “not in light space”. Not sure what that means though.

Hi @an1645a,
Thanks for the information.

A write timeout indicates that odrive is attempting to send data to the remote service, but is unable to write to the stream within a certain period of time. This type of issue is actually pretty rare. It may indicate that there is something on your system that is preventing uploads.

What is the typical upload speed you get on your internet connection?

Can you run a few tests?

  1. Are you able to upload a very small test file? (less than 5KB)
    2 Are you able to upload a small test file? (Greater than 1MB but less than 5MB)
  2. Are you able to upload a medium test file? (Greater than 10MB but less than 50MB)

Do you know if there is anything in your environment that might get in the middle of things? (anti-virus, endpoint protection, network monitoring, VPN, firewalls, proxy, etc)?

Do you have any other systems where you can test a large file upload via odrive?

I went to and I get around 2-9 Mbps for the upload.

I have been able to manually upload large files (~2 GB) to the google drive.

I did notice that some .nfo files (1 KB in size) were being uploaded through odrive.
Also, I was playing around stopping and refreshing the odrive sync in various folders and I managed to upload a few files which were around 1MB in size. It’s gone back to being stuck again however as it’s trying to upload my larger video files.

I do have a second laptop I use that is connected to odrive, but that is currently fully synced so I will find a large file and see if that syncs and get back to you.

I was able to upload large files without issue from my other laptop. As I said in the previous post, that computer is fully synced so it doesn’t have a large backlog of files waiting to be synced. Also, it is using prod 6964 of odrive.

Thanks @an1645a!

The backlog, itself, isn’t a problem. Odrive is actively attempting to upload but continually encountering network errors and retrying. My guess is that there is something on the system that is interfering with the upload.

Do you have any applications running that could be causing an issue, like the ones I mentioned in my previous post?

Another good test is to create a new Windows user on the same machine, run odrive with that user (using the same odrive account) and test uploads with that new Windows user. That will remove any user-specific environmental factors.

I created a new user on my computer and ran odrive there. I am getting the same error:

[Errno 10053] An established connection was aborted by the software in your host machine

So it seems there is some software on my machine that is preventing this from otherwise working properly. Do you have any suggestions to figuring out what it may be? I’m turning off my Microsoft Defender Firewall for the time being and will try to see if that does anything.

Hi @an1645a ,
Thanks for running those tests. I wish it was easier to figure out what is going on here…

  • Were you able to test a medium sized file on the computer? (Greater than 10MB but less than 50MB). Did that end up working? I am wondering what the cutoff is.
  • Is it possible that there is something specific about the files that are not uploading?
  • Are they all greater than 50MB?
  • For the large files that you successfully uploaded on your laptop, did you try those same files on your desktop?
  • If you open the Windows Task Manager and go to the “Startup” tab, you can see all of the applications that start automatically. Take a look at these and see if any stick out as either program you don’t recognize or programs that could be doing any sort of monitoring/blocking.

Hi Tony,

I started disabling more and more apps and it appears like it was what you said, a network monitoring app running in the background that was the culprit. I was able to start uploading files again so I think my issue is resolved.

For the record, the app was NetWorx. I have the same app on my other laptop which was uploading properly so I’m not sure why it was blocking the connection on my desktop computer, but nonetheless now that it is removed I can upload.

1 Like

Great! Thanks for the follow-up @an1645a .

This may help others that run into the same issue, in the future. It is certainly odd that it is only affecting one system, though.