Error updating file. Size Mismatch

Tony, what would cause this problem? FYI, I just installed Odrive2. I’ve never seen this warning before.

Hi @jeremy5,
There was an enhancement added to odrive1 recently (Desktop Release (05-17-2018) Win v.6317 / Mac v.6386) that does a final check on the file being downloaded to ensure that it is the same size as the remote storage is reporting. If it is not the same size then you will see this error.

Are you seeing this for many files, or is it this specific file type, or just this one file?

—Edit for people that may come to this thread after seeing this error—
We added the ability to disable this check, if required. See this post for more details:

So far just this one file, I am not sure if other files are effected as I haven’t been sync’ing a lot of files recently.

How do i get past this so that it will sync? The file has not been sync’ed to this point, so I am not sure how it was able to compare the file size.

Hi @jeremy5,
What is happening here is that odrive is attempting the sync (download) and, before it considers the file synced, it compares the size of the temporary file to what the remote storage is reporting. If it doesn’t match then it discards it. This is done because the file is incomplete, according to the remote storage, so it can’t be considered “synced”.

The web browser does not have the same check, so can you see if the file is downloadable via the odrive web client. Is it also downloadable from the Box web client?

I’ve been able to download it from odrive and, no problem. But, of course, the reason I love odrive is that I don’t have to manually download updated files. How can I get this sync’d with my hard drive? In the past i’ve just right-clicked on the “cloud” file and selected “sync” and it sync’d right up.

Weird! I downloaded manually, and then sent the message above. Just for fun, I tried right-clicking on the file again and selecting “sync” and it worked. :thinking::confused:

I just tried sync’ing another “cloud” file and it worked as usual. Maybe it’s just a fluke?

Thanks again!

Hi @jeremy5,
Thanks for the update!

Hitting this issue should be very infrequent. It can happen if the remote storage is incorrectly reporting the size of the file, which could indicate a metadata error, or some latency in the reflection of the new file state, if it has recently been modified (basically it is showing the old info). This can also happen if the download of the file is cut off unexpectedly, but an error is not raised. This is even more rare, but is possible.

In any case, I am glad to hear that things are working as expected now!

I’m running into this problem too as of today (Windows, odrive1 6333). I have several hundred files that are .cloud on a OneDrive account, and I can’t sync them. I can download them directly from OneDrive, and from the Odrive web explorer, but cannot get them to sync. (Size mismatch on individual files and parent folders of those affected files)

I’ve tried unlinking my account, and relinking. I resynced the entire OneDrive folder, and it downloaded all of the files except for the ones I was having troubles with.

Any suggestions on where to go from here?


Hi @jsoenneker,
Is there anything that these files share in common? This should only ever happen if the file that is stored on the remote storage is not the size that the remote storage reports it to be.

If you download one of these files from OneDrive’s web client, then re-upload it, does it sync properly via the odrive desktop client?

Can you send a diagnostic from the odrive tray menu?

@Tony There isn’t anything that I can tell these files share in common. They are spread out, apparently randomly, across different folders.

If I download the file via OneDrive, delete the file on OneDrive, re-upload via OneDrive web, I’m able to sync the file successfully.

I’ve sent a diagnostic via odrive tray menu.


Thanks @jsoenneker,
Can you install this test version and take a screenshot of the mismatch error. This adds info about the sizes. I am curious as to the difference between what is reported by OneDrive and what is downloaded:

Thanks @Tony, I don’t receive a size mismatch error any longer with 6341. Instead I get the following: “Unexpected error. Please try again later.”


I’ve sent another diagnostic via the tray.

Hi @jsoenneker,
My apologies. I had a bug in the messaging that I missed when trying to get this out quickly. Can you try this one?

Hi @Tony,

Attached is the error I get with 6342. This is after clicking sync on one specific file, not a folder.


I’ve sent another diagnostics.


Thanks @jsoenneker. Unfortunately the diagnostic didn’t seem to come through. Can you trigger the error on a few more files of different types and sizes and then send 2 more diagnostics, for good measure. Hopefully they’ll come though.

I just want to validate the mismatch and see how far the sizes are off, and if there is any pattern in the various files. The new diagnostics should show me that.

Diagnostics sent. Thanks for your help @Tony. Let me know if I should do anything additional.

Thanks @jsoenneker,
Here is an example of what I see in the diagnostic:
Documents/Vehicles/2000 Volkswagen Golf TDI/limit.png - Size mismatch while updating file ( 52503 vs 89501 )

For this file, the size of the file that was downloaded was 52503 bytes and the size of the file, as reported by OneDrive, was 89501 bytes.

Another example:
Documents/Vehicles/2000 Volkswagen Golf TDI/DIY.docx - Size mismatch while updating file ( 14532 vs 91555 )

For this one, the size of the file downloaded was only 14532 bytes and the size reported was 91555 bytes.

I don’t see any sort of pattern, unfortunately. Another example was only a difference of about 500 bytes, while the ones above are off by several thousand.

Here are some things we can look at:
For the two files above, when you download themusing the OneDrive web client, how large are they? (right-click properties after downloading).

If you try to download these same files again through the odrive desktop client, to they produce the same error? If so can you send one more diagnostic afterwards? I would like to see if the numbers are exactly the same or have changed. Try them a few times each.

My apologies for all of the tasks here. I just want to make sure we have a clear understanding of this.

Great suggestions. So here’s what I know now:

  1. For limit.png, after downloading via OneDrive, via Windows properties I see the file is at 52503 bytes. This same file when in OneDrive web, info page, says it’s 89501 bytes. I opened it file via OneDrive, and ended up copying it to a different location within OneDrive web, and then it shows the file at the proper size.

  2. For DIY.docx, same situation with file sizes. I opened it up via OneDrive’s document viewer, and sure enough OneDrive web properties changed via the info page to the correct size.

I can download the files fine through odrive once OneDrive acknowledges the right size of the file. Perhaps there was a bug in OneDrive when these files were uploaded, or maybe there was an issue with odrive software since these files were added to OneDrive via odrive. I’ll probably try moving folders/files around within OneDrive to get all of the files to be recognized as the right size on the platform.


Thanks for the follow-up and additional information @jsoenneker!

It is definitely a very strange issue. When odrive sends data to OneDrive it indicates how large the data is so that OneDrive knows when the file is done uploading. If odrive had indicated the file was larger than the data, the upload would have never completed. It would’ve ended up timing out since OneDrive would sit there waiting for the rest of the file.

Hopefully you don’t have too many of these types of files. Do you know if these files were all uploaded around the same time?