Desktop client not start on Surface Pro 10

Hi,

I have installed odrive desktop client prod7268 on Surface Pro 10.
Install has finished, but odrive.exe won’t start. I cannot see any windows.
I have restored Surface Pro to factory default and installed odrive, but I got the same error. I have stopped windows defender, but the same.

Event Viewer leaves following logs and dumps.
Does anyone have an idea what I should do next?

EventData
AppName odriveapp.exe
AppVersion 0.0.0.0
AppTimeStamp 00000000
ModuleName ntdll.dll
ModuleVersion 10.0.22621.3527
ModuleTimeStamp b71c4741
ExceptionCode c0000005
FaultingOffset 00057a52
ProcessId 0x4754
ProcessCreationTime 0x1dab17114295086
AppPath C:\Users\USERNAME.odrive\bin\7268\odriveapp.exe
ModulePath C:\WINDOWS\SYSTEM32\ntdll.dll
IntegratorReportId 02fcea98-6ab2-457d-81a6-8d5ae042db4b
PackageFullName
PackageRelativeAppId

0:000> !analyze -v


  •                                                                         *
    
  •                    Exception Analysis                                   *
    
  •                                                                         *
    

*** WARNING: Check Image - Checksum mismatch - Dump: 0x1b47ed, File: 0x1b18ff - C:\ProgramData\Dbg\sym\ntdll.dll\B71C47411b1000\ntdll.dll
DEBUG_FLR_EXCEPTION_CODE(c0000374) and the “.exr -1” ExceptionCode(c0000005) don’t match

KEY_VALUES_STRING: 1

Key  : AV.Fault
Value: Write

Key  : Analysis.CPU.mSec
Value: 1890

Key  : Analysis.Elapsed.mSec
Value: 8327

Key  : Analysis.IO.Other.Mb
Value: 11

Key  : Analysis.IO.Read.Mb
Value: 0

Key  : Analysis.IO.Write.Mb
Value: 27

Key  : Analysis.Init.CPU.mSec
Value: 624

Key  : Analysis.Init.Elapsed.mSec
Value: 125773

Key  : Analysis.Memory.CommitPeak.Mb
Value: 83

Key  : Failure.Bucket
Value: INVALID_POINTER_WRITE_c0000005_heap_corruption!odriveapp.exe

Key  : Failure.Hash
Value: {8045b0d5-87c3-4dcf-963c-701f93f9a6f8}

Key  : Timeline.OS.Boot.DeltaSec
Value: 70739

Key  : Timeline.Process.Start.DeltaSec
Value: 1

Key  : WER.OS.Branch
Value: ni_release

Key  : WER.OS.Version
Value: 10.0.22621.1

FILE_IN_CAB: odriveapp.exe.20440.dmp

NTGLOBALFLAG: 0

APPLICATION_VERIFIER_FLAGS: 0

CONTEXT: (.ecxr)
eax=00000448 ebx=00e62568 ecx=0000384e edx=0000007f esi=00e62628 edi=00e60000
eip=77bbfdc1 esp=0064cc00 ebp=0064cd30 iopl=0 nv up ei pl nz na pe nc
cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010206
ntdll!RtlpFreeHeap+0xc11:
77bbfdc1 668944cb04 mov word ptr [ebx+ecx*8+4],ax ds:002b:00e7e7dc=???
Resetting default scope

EXCEPTION_RECORD: (.exr -1)
ExceptionAddress: 77bbfdc1 (ntdll!RtlpFreeHeap+0x00000c11)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 00000001
Parameter[1]: 00e7e7dc
Attempt to write to address 00e7e7dc

PROCESS_NAME: odriveapp.exe

WRITE_ADDRESS: 00e7e7dc

ERROR_CODE: (NTSTATUS) 0xc0000005 - 0x%p 0x%p Q B %s B

EXCEPTION_CODE_STR: c0000005

EXCEPTION_PARAMETER1: 00000001

EXCEPTION_PARAMETER2: 00e7e7dc

ADDITIONAL_DEBUG_TEXT: Followup set based on attribute [Is_ChosenCrashFollowupThread] from Frame:[0] on thread:[PSEUDO_THREAD]

FAULTING_THREAD: ffffffff

STACK_TEXT:
00000000 00000000 heap_corruption!odriveapp.exe+0x0

STACK_COMMAND: dt ntdll!LdrpLastDllInitializer BaseDllName ; dt ntdll!LdrpFailureData ; !heap ; ** Pseudo Context ** ManagedPseudo ** Value: ffffffff ** ; kb

SYMBOL_NAME: heap_corruption!odriveapp.exe

MODULE_NAME: heap_corruption

IMAGE_NAME: heap_corruption

FAILURE_BUCKET_ID: INVALID_POINTER_WRITE_c0000005_heap_corruption!odriveapp.exe

OS_VERSION: 10.0.22621.1

BUILDLAB_STR: ni_release

OSPLATFORM_TYPE: x86

OSNAME: Windows 10

FAILURE_ID_HASH: {8045b0d5-87c3-4dcf-963c-701f93f9a6f8}

Followup: MachineOwner

Hi @mzd3,
Can you tell me what processor this Surface X has and what version of Windows?

If it is an ARM processor then it will need to use emulation to run the odrive app. I know there are some users that have verified this works, in the past, but it is not a configuration we build or test for.

Hi Tony

“Surface Pro 10” has Intel Core Ultra 5 processor 135U or Core Ultra 7 processor 165U.
My surface has Core Ultra 5 -135U.

“Surface Pro X” has ARM processor.
X is not 10. Very confusing model names.

Hi @mzd3,
Thanks for the information.

This is definitely strange. I don’t think we’ve had any reports of Windows crashes in a several years, and even those were related to 3rd party software being in the mix (antivirus/endpoint protection/malware scanning, network monitoring/management, driver interference, and the like).

This is Windows 11?

Is there any other software running that could be scanning or monitoring files, processes, or system activity?

Hi Tony

OS is Windows 11 Pro
OS Name: Microsoft Windows 11 Pro
OS Version: 10.0.22631 N/A Build 22631

When I installed odrive on Surface Pro 10, it didn’t start. I thought any other software might cause conflicts, so I decided to install odrive on Vanilla Surface Pro 10, and I restored windows 11 pro. But the same error happened.

I found the new client Win v.7272 released and installed new one, still same error happened.

Hey @mzd3,
I’ve been looking at this, but I haven’t been able to identify an issue in the software yet.

Can you try the following?

  1. Open a command prompt
  2. Copy and paste the following command and hit enter:
    powershell -command "echo %time%; &{$bin=$(ls \"$HOME\.odrive\bin\" | sort Name -desc | select -f 1).FullName; & \"${bin}\odriveapp.exe\";}"; echo %time%

If the application stops again, does anything print out to the prompt?

Hi @Tony

The command showed “echo time” twice.

powershell -command “echo %time%; &{$bin=$(ls "$HOME.odrive\bin" | sort Name -desc | select -f 1).FullName; & "${bin}\odriveapp.exe";}”; echo %time%
9:47:02.95
9:47:02.95

Thank you for your support.
I’ll wait another version of the desktop client and surface driver updates.

Hi @mzd3,
Do you happen to be running a 32bit version of Windows? If so, I think that could be the issue.

We have some tweaks to make more use of memory that could be affecting a 32bit installation. 32bit Windows installations are very rare nowadays, which would explain why we are only seeing this with your system.