Desktop App stops after a few seconds (Mac)

The app works fine occasionally, but most of the time it doesn’t start upon start of the computer (even though defined as start object). After manual opening it shows up for a few seconds in the menu bar and then disappears. I already re-installed the app, same result. With this behavior odrive is useless.

iMac (Retina 4K, 21.5-inch, Late 2015)
3,1 GHz Intel Core i5
macOS High Sierra (10.13.6)

Hi @beli120805,
It sounds like this problem is intermittent, is that correct? Or are you seeing that the app is closing a few seconds after starting, every time?

Have you tried a full uninstall and reinstall yet?

To do this, perform the following steps:

  • Uninstall odrive using the instructions from How do I uninstall odrive?. Uninstall will rename the current odrive folder, as a backup. More on that below.
  • Install odrive again.
  • Once odrive is back up and running, make sure it is working properly.
  • When you uninstall odrive it will rename the current default odrive folder to a backup name. You will find this folder in your user home directory named odrive_[current date and time] .
  • Exit odrive
  • Rename the current odrive folder to odrive-bak
  • Rename the backup folder that the uninstall created back to just ‘odrive’.
  • Start odrive again

odrive will see the folder and process the content in it. If you have lots of content it could take a while for odrive to finish processing, but once it has you should then be able to proceed as normal.

I mentioned that I re-installed the app to avoid getting this standard reply. The problem is indeed intermittent.

Hi @beli120805,
My apologies. I have found that many times a “full” uninstall and install hasn’t been completed when a user attempts a re-install of the software. The complete process requires a terminal-based command that clears out all of the resident persistence and binaries, as per this post:

If that terminal command was already run then we will need to dig deeper.

A few questions:

  • Did this problem just start occurring, or have you encountered it from the beginning of using odrive?
  • If it was something that suddenly came up, was there anything that changed or was added on the system around that time?
  • If you double-click on a .cloud or .cloudf file when odrive is not running, will it launch and stay running?

The next time this happens please perform the following steps:

  • Open the Console app (type console in spotlight search) and filter for odrive at the top right. Make sure to hit return after entering odrive for the filter to take effect. See if there is anything here that stands out during the time that the odrive app disappears. If there is, please copy and paste it here so I can take a look.

  • Still in the Console app, click on “System Reports” on the left-hand side, under “Reports” and see if there are any reports with odrive in the name around the time of the disappearance. Do the same for “User Reports”. If there are, please message those to me (click on my name and then click “Message”)