Constantly having to reset odrive

Twice in the last few weeks I turned my computer on and got a “Welcome to odrive” message. All my files - both the synced files and the cloud files - had disappeared. I had to reset odrive and all my files came back as unsynced cloud files - so the many gigabytes I had synced on my local drive had to be resynced. That takes quite a long time and is very worrisome - why is odrive suddenly deciding to exit my computer!? I am accessing Box, Google Drive, Dropbox, Onedrive.

Hi @fwsawyer,
This sounds like what happens when odrive detects problems with its local database and has to create a new one.

odrive stores its local cache information in a .odrive folder (with a leading period) in your user home directory. If there are issues encountered with reading that information, odrive will create a new one and backup the current odrive folder. I have seen this happen when the hard drive is failing or having issues.

I have also seen this if the .odrive folder is removed, either by other applications or because of roaming profiles, for example.

Do you see any ‘odrivebackup’ folders in your user home directory?

Thanks for getting right back to me. Yes, there is backup folder. Don’t know how to use that to prevent having to run through a full sync session again. I got the sync putting files back on my local drive. Suddenly that stopped and odrive disappeared. Nothing in the taskbar. The odrive folder is still there along with the .cloud files - but they’re useless because odrive isn’t running - so no sync. I ran odrivesync - that asked me if I wanted to do a repair. I did and it said the repair had been completed. No noticeable change and no odrive running. I tried running odrive.exe but it said there was an existing installation that would have to be removed first. If I do that, will all my local files need to be replaced again? Why is odrive flaking out?

Hi @fwsawyer,
This is definitely not normal behavior.

I expect that there is something happening that is causing this. Is your computer running normally otherwise? Has it had any sudden power outages, or experienced any errors? My first thought would be a hard drive malfunction.

In any case, let’s try these steps to see if we can get things back on track:

  1. Uninstall odrive - This will remove the cache and rename your odrive folder to an odrive backup folder
  2. Reinstall odrive
  3. Go through the odrive setup process and log back in. Make sure you are logging in with the exact same odrive account as before.
  4. Once odrive fully initializes the go to the new odrive folder, which should now have all placeholder (.cloudf) files. The cache has now been reset.
  5. Now, go to the backup odrive folder that was created during uninstall (odrive_backup-YYYY-MM-DD-HHMM) and move all of the folders inside that backup folder into the new odrive folder. These will end up replacing the .cloudf files in there (odrive will remove them when it sees that the “real” folders are now present).

At this point odrive will run through the folders and make sure everything is synced. Let it run (it may take a while) and it should eventually bring everything back in sync. After that we will have to monitor things to see if the problem happens again.

Thanks. I have done all of that and it seems to have performed as you indicated it would. At the moment everything looks good. But note that this is at least the second time in the last month or so that the exact same thing has happened.

Thanks for the follow-up @fwsawyer. Hopefully you won’t see it again.