(conflict) files generated when syncing from different systems

Hello everybody,

I had to replace my computer recently and I am now using a different machine to sync my odrive files from an external usb device. However, with this new machine my files produce “(conflict)” versions instead of updating/overwriting the existing ones…
Is there any way around this? I know that syncing the same folder from different machines is not supported, but in my case I would no longer be syncing with my previous system.

Thank you in advance!

Hi @josef.piras,
Can you reproduce the conflict scenario and then send a diagnostic from the odrive menu so we can take a closer look at what is happening?

Please update this thread when you are able to do so.

Dear Tony,

thank you for your quick reply and for looking into this issue. In my Amazon Drive Folder there happened to be some duplicate folders and (conflict) files. I already deleted some of these but others still remain.

However, while sending the report I noticed something potentially even more worrying: there are about 127 “Not allowed” files, the majority of which belonging to my Box account.
The exception raised simply says “Box encountered a conflict” without any further clarification. What is very concerning (I do not know how bad this might be, but when it comes to data I tend to be rather paranoid) is that the Box folder on my odrive online platform seems to contain all my locally stored files. The Box online platform however does not and there are many files missing… What does that mean?

Thank you again and sorry if I am overlooking anything!

Hi @josef.piras,
It looks like odrive is still in the process of trying to upload items, which can explain why you don’t yet see everything up on the storage.

I did not see any recent (conflict) file generation, so I can’t tell exactly why that was occurring. However, given the conflict errors you are seeing with Box in “not allowed”, I suspect that there is some intermittent latency where Box is not reflecting the files that were uploaded (odrive asks for a listing of the files and the files that were recently uploaded are not being listed). The delay is significant enough that odrive can’t account for it and it starts to encounter these types of issues with conflicts. For example, odrive uploads a file and tries to retrieve the listing of that file on the storage, but it isn’t listed. It tries to then upload it again, but it is already there and encounters a conflict scenario. This can also happening if odrive uploads a file, but the storage gives an error back, so it tries to upload it again, but the file actually made it up, despite the error. I have seen this happen with Amazon Drive and Box, in the past.

What may help is to restart odrive and then let it run for quite a while to see if some of these issues can be cleared and odrive can finish uploading anything that is pending.

Once activity seems to have subsided, take a look at what is in the “not allowed” and “waiting” queues. The items in “not allowed” will likely be remote files that cannot be downloaded locally because of illegal characters and local files that cannot be uploaded. In the case of remote files with illegal characters, those would need to be renamed on the remote side to remove the offending characters ( / \ : are the common ones). For items that can’t be uploaded, you will need to see what those errors are. If you still encounter conflict errors, you can rename the local file to allow them to be uploaded.

Dear Tony,

thank you very much for your help and explanation which provides a very good insight into what may cause this strange behaviour. I tried running odrive for some hours, to the point where the Box folder would still have a red sync icon but I could not get any information on what exactly was being uploaded. However next time I checked all of my Box files where gone. Even on the local folder they seemed to have been deleted in the process.
Fortunately I could restore them from an offline backup and tried syncing them again.
This time everything uploaded flawlessly and all files are now displayed on the odrive and box platform as well. I am glad the issue is solved now, but it is mildly worrying that I do not understand the inner workings of the syncing process.

Thank you again for your help and time!

Hi @josef.piras,
Thanks for the update! I am glad things are all sorted out now, but I am concerned about the missing files you saw.

The files being deleted is definitely very strange. Did you see them in the Box trash? (https://community.box.com/t5/Managing-Files-and-Folders/Manage-Trash/ta-p/19212).

I’m not sure what would cause that to happen on both sides, unless Box was reporting the deletes. odrive has its local trash that will hold any local deletes to prevent them from going to the cloud, as a safeguard against accidental deletes. Since the files were gone from both sides it sounds like Box was reporting them as gone?

Dear Tony,

yes, the deleted files are in the Box trash! I have no idea how they ended up there in the first place though. And yes, the fact that they were removed locally too is even stranger. My understanding is that odrive would not sync deletes coming from the various cloud services but instead place them in the odrive trash. Am I missing something?

Thank you again,

Hi @josef.piras,
If the deletes originated on the local system, they would be held in the odrive trash and wait for confirmation before sending the delete commands to the cloud.
If the deletes originated in the cloud (or from a non-odrive client), odrive will see that the files on the remote side have been deleted and sync those deletes locally. In this case those files that were deleted locally because of the remote deletes should be moved to the operating system trash/recycle bin, if possible.