.cloud placeholders taking up full space (Linux Mint)

I’m running Linux Mint 21.2 on a laptop (Dell Latitude 5320). I quickly filled up my system running a recursive sync with --nodownload. I looked at what was taking up space and it was individual .cloud files taking up the amount of space of the full file. Unmounted and syncing individual folders shows the same thing, the .cloud files appear to take up the full space of the unsynced file.

I have a near identical installation running on a desktop without these problems. The only difference I can think of is that the laptop has an encrypted hard drive. Is likely to be the cause of this?


Hi @leosaffin,
The client creates “sparse” files to represent the file size without taking-up space. This generally works on most filesystems, but it may be that the encryption causes the sparse creation to actually take-up space on the disk.

If this is the case, you can disable the creation of sparse files, so that they are just empty files (show as 0 bytes). This requires a change to an advanced configuration setting:
Advanced client options

Just change ‘disableSparse’ from false to true in the ~/.odrive-agent/odrive_user_general_conf.txt file and restart the agent. All new placeholders will no longer be sparse.

That works great. Thanks.

1 Like