Character limit

Hi, I’ve started running into a couple weird issues with Odrive and character limits for the file name. The name with path is greater than 256 characters, but I have edited the registry to allow long path names. Since editing the registry, if the files are outside of the odrive folders they are able to be opened normally (despite the name+path being over 256 characters). Once moved into the odrive folders, the exception from the registry no longer applies and I am once again limited by the 256 character maximum. This applies to files put into Google Drive & Procore then synced by odrive, and files that I put into their odrive directories and then had sync to Google Drive & procore.

Is there a different location for the character limit? The total characters has been 260-300 characters for the files

Hi @gsvanas,
There actually should be no difference between synced odrive folders and any other folder on your system since they are all the same at the filesystem level.

Can you provide an example of a long path that works and one that doesn’t?

Can you also post the error you are seeing and tell me what app is displaying it?

Hi @gsvanas ,
I wanted to follow-up on this. Please let me know when you are able to take a look at my questions above.

I’ve been testing some various paths/files with the user and I’ve narrowed down the issue to being just Bluebeam Revu not supporting the registry modification for 256 characters. Bluebeam themselves state that the program doesn’t support file names over 256 characters - and the files work when opened with other pdf readers/editors.

The odd part seems to come from how it gets to the folder - if it’s never uploaded/synced/touched outside of getting a long name, Bluebeam seems to fairly consistently be able to open the file - but once Google Drive/procore/odrive/whatever touch it, it’s done for.

This can be considered resolved since the issue is directly related to Bluebeam “While a recent Windows update has made it possible to raise file path character limits, Revu is currently not compatible with file paths longer than 260 characters.”: Studio Error: "The Project file path is too long."

Thanks for the response @gsvanas!

I had actually attempted to work with Bluebeam to address this a few months ago, after doing a bunch of testing. Unfortunately I wasn’t able to get any traction and pretty much ended up where you did with them.

To help combat path-related issues, you can use the “sync to odrive” functionality to “short-cut” the path to your projects folder, or to specific project folders.

Here is an example of how to do that for the projects folder:

  1. Create a new local folder C:\projects
  2. Right-click on this new ‘projects’ folder and select “Sync to odrive”
  3. In the browser that pops-up, select the Procore/[Procore company name here]/projects folder and click Okay.

This will create a new odrive sync folder that starts at C:\projects and maps to the Procore projects folder. This cuts out a significant amount of characters from the paths ( removes Users\[user name here]\odrive\Procore\[company name here] )

This same thing can be done at any level of the path.

Example screenshots from my own system:

I will definitely keep this in mind! Thank you! Right now the cases of file names being too long is a bit sparse and niche in the environment, but this could save me a lot of headaches in the future

1 Like