Can't sync to google drive

Recently, my M1 Mac can’t sync to google drive. I can’t know what the problem is. Please help.

Hi @lichang.liu,
Can you describe the behavior you are seeing? Are there any errors?

Can you send a diagnostic from the odrive tray menu, so I can take a closer look?

Also, if you click on “Open sync activity log” at the top of the orive tray menu under “Ready to sync new changes/Syncing changes”, a detailed log of all of the sync activity will open. That may provide some additional information on what is happening. Can you attach that file here, as well?

Yes, here is status 7hr ago: current_odrive_status.txt (7.4 KB)

and here is status now: current_odrive_status.txt (167.4 KB)

still waiting for one file and the other file stail on 11% progress

Hi @lichang.liu,
It looks like odrive is attempting to upload, but encountering errors when doing so.

Can you try the following steps?

  • Go to “Syncing Changes” at the top of the odrive menu and select “Stop automatic Sync”. This should put the two files into “Waiting”
  • Add two smaller files to the same folder (odrive/Encryptor/_NetNAS/_Media/_Animation倉庫/_tmp/) folder. One file should be less than 50MB and the other file should be between 50-100MB.
  • Go back to “Syncing Changes” at the top of the odrive menu and select “Start automatic Sync”

I want to see if the small files upload or also have issues. Please send a diagnostic after this.

Hi I do steps as above, here is status report: current_odrive_status.txt (195.6 KB)

Hi @lichang.liu,
The errors seem to point to a network issue of some kind. Are you experiencing any network issues?

Can you try restarting your system, when you get a chance and then see if that improves the situation at all? If not, can you send one more diagnostic and also see if the smaller files upload or also have issues?

I don’t get any network issue and I rebooted mbp twice since last weekend.

Hi @lichang.liu,
Okay thanks.

Can you at least perform an odrive restart? I would like to see a diagnostic after an odrive restart and upload attempt.

I restart odrive, here is report: current_odrive_status.txt (21.1 KB)

Hi @lichang.liu,
It is difficult to tell what is going on except that the network connection is having issues. This could be a networking issue, or it could be that Google is severing the connection during upload.

  • Can you try uploading the same smaller file to a Google folder outside of Encryptor? (in ‘odrive/Google Drive’, for example). I want to see if the same error occurs outside of the Encryptor folder.

  • Can you also double-check that your storage on Google Drive seems okay? We should be getting an error back (instead of the network connection breaking) if there is insufficient storage, but I just want to make sure that the Google account looks okay.

  • Can you also try uploading the same file to a few of your other linked accounts? (odrive/OneDrive, odrive/Dropbox, and another Google Drive account, for example).

At this point I am just trying to eliminate variables to see if we can isolate the error here.

  1. I put to outside of Encryptor: current_odrive_status.txt (359.2 KB)
  2. I can uploag to google drive using browser, and my account is unlimited storage G suite
  3. unable to upload to other odrive related account: current_odrive_status.txt (370.5 KB)

Hi @lichang.liu,
Thanks for continuing to help me troubleshoot this.

The symptoms and errors you are seeing point to something interfering with the network (VPN, proxy server, network monitoring software, virus scan software, endpoint protection, etc). I have seen this a few times before where there was something getting in the middle of the connection between odrive desktop client and the remote storage. Basically odrive is unable to establish a reliable connection to Google when attempting to upload. Unfortunately, network errors like these are not very descriptive, so there isn’t any more information to go off of.

  1. It doesn’t looked like you tried uploading to Dropbox or OneDrive from the odrive desktop client. Are you able to give that a try?
  2. Are you able to download from Google Drive using the odrive desktop client?
  3. Are you able to upload to your Google account via the odrive web client (
  4. Has anything on your network changed or have you recently installed any software that might be performing security, network-related monitoring, or system monitoring?
  5. Do you use VPN, a proxy, or any other networking related configuration that could be involved?

I think I found the issue. I use proxyman to help my work, but it seems have issue with odrive

1 Like

Ahh, okay that sounds like it could be it @lichang.liu . Does uploading seem to be working better when proxyman is disabled?

I will try it. Thanks for helping.

1 Like

Did you find a way to sync or not?

yes, it’s work now. Thanks for help @Tony

1 Like