Can't get around - Waiting changes will auto retry

I’ve been reading the forum and see others with this problem but the helpful posts are from September and refer to release 5983. Based on the package contents, look like I’m running build 6149.

I’ve tried numerous ways to “throw away” the offending file but they all generate errors of one kind or another. Running on macOS Sierra

Sync is stuck. How can I break this logjam?

Hi Steve,

Can you describe what you’re trying to do and the problem you’re facing in more detail? I’m not sure what’s going on exactly, but we’d like to help fix the problem.

For example, these are some things we’d like to know:

  • What are you trying to do exactly?
  • What did you do before you hit this issue? e.g. Did you drag a bunch of files into a link folder and they go into Waiting and they never finish retrying?
  • Is this happening with a bunch of files or is it just plugging away trying to get a single file up?
  • How big are these file(s)?
  • What kind of file(s) are they?
  • What source are you syncing with?

You can also try clicking on the odrive tray icon and selecting to Send diagnostics (let us know when you’ve done that so we can look out for it).



Thanks for replying.

I’m in the initial sync phase. I have several services gDrive, Box, etc that I want to sync.

I started with a google drive account and did the following:

  • linked the account
  • Double clicked the root to populate
  • right clicked to sync one of the small folders, which worked
  • several other sync operations of increasing size worked
  • then right clicked on a larger folder with sub folders and let it rip
  • satisfied, I moved on to sync everything by selecting the root and choosing sync
  • some time later, found waiting… on file named 04_r0053.html, size 2K (hundreds of others worked)
  • all sync is halted because of the waiting state

Ah, thanks for the info. Very helpful.

If you’re still in this state, can you go to the tray menu and select to Send diagnostics? Let us know when you’ve done so.

You should only see the file go into Waiting if we’ve hit some sort of network error. Google Drive also has some fairly aggressive rate-limiting, but you shouldn’t see the Waiting issue (we handle it a bit more transparently internally to throttle/regulate in case a rate limit is hit).

After you’ve sent diagnostics, you can try to get around the problem by exiting the client and restarting. Then go to the same top-level folder (you may see a green checkmark here but that means it’s in sync but possibly with placeholders inside still) and restart the sync job to try to continue downloading everything again from where it left off.



I sent the diagnostics some time last night, can’t remember when.

Yes, I’ve been restarting the client and that has worked but also proved to be too labor intensive. After a restart, I still can’t get the automated root sync to complete. I get the error: “Unexpected error. Please try again later”.

I can sync some 2nd level folders without errors by clicking Sync. Other 2nd level folder sync operations yield this error where 04 is a subfolder name. “Can’t sync 04. Item does not exist on odrive.”

The real problem for me is the error messages are not specific enough to figure out what the problem is.

Thanks for your help

Thanks Steve. As a quick update, we’re looking at the diagnostics. We’ll update you once we have some next steps or things to try.


Unfortunately, the diagnostics seem to indicate that your app is in some sort of unexpected odd state internally (it shouldn’t affect your data in the cloud). Can we reset it and try again to see if it’s reproducible?

To reset the client, you can:

  1. Go to the tray menu -> Authorized user -> Deauthorize. Clicking this will cause your client to exit and restart. In doing so, you will get a new odrive home folder which will be in your user’s home directory as “odrive(1)”. Your old odrive folder “odrive” will still be there just in case. (It’s a good idea to keep it around for a couple of weeks just in case).
  2. When odrive restarts, go ahead and sign in again.
  3. Now, rename your old “odrive” folder to “odrive-old”
  4. Rename your new “odrive(1)” folder to “odrive”
  5. Go to your tray menu -> Open odrive(1) folder [missing] -> select the new “odrive” folder from step 4.

That should get you back into order. Steps 3-5 are optional if you want to just use “odrive(1)” as your odrive folder, but it’s a little nicer to do the renaming once.

Your new odrive folder will start out as placeholders again. Sorry about that, I know you had put some time earlier into downloading a lot of your content. If you could then try to right-click -> Sync on your Google Drive root folder again, hopefully we can see if some of those issues go away.

Thanks, and we appreciate your efforts,


About an hour ago I finally got everything to sync.

I changed strategies: Instead of downloading the data, I moved the data from the google drive sync folder into the corresponding odrive folder. Not only was it faster, but it also threw very few errors.

I now have only a few stray issues that I’ll open as separate topics if I can’t get them straightened out.

Okay, sounds good.

Perhaps later on sometime if you can Send diagnostics again (and post here), that might make me feel better, too, given what I saw earlier… I’d like to make sure you still don’t need to run the reset steps above.


Jeff, I just sent fresh diagnostics. The odrive client seems pretty happy now. Let me know if there’s a knot in there.


Diagnostics indicate your client is mostly healthy. I’ve got only one question / one thing to follow up on which I’ll send you a PM about.



Yes, I do have a My Garmin folder. I’ll look into that.

I have noticed one problem though and I was waiting for your response before doing anything rash and assuming it was caused by a bad state. The issue is that some new files are not syncing with a box account.

I have two machines linked to the box storage. One via the box client and the other via odrive client. I added files on the machine wth the box client and then checked the odrive machine to see if they showed up. They are not showing up. The folder in question is called xDrive/Invoices/USAA. The files do appear on the box web page as being synced to the cloud.

In addition, when I right click on Invoices or USAA, the only context menu item that appears is No Options Available.

I feel like there is a step I’m missing. I’ve selected sync everything at the root of the box mount point.

Any suggestions?


Hi @steve.davies.iphone,
For this particular issue, can you please do the following?

Provide the full path the the folder that is not showing the files and a couple of the file names.
Send another diagnostic from the odrive tray menu
Check the contents of the folder from the odrive web client. Do you see the files listed there?


I replied to your @odrive address.


Hi @steve.davies.iphone,
I took a look a the diagnostics. I do not see a smoking gun, in terms of Box sync, but here are a couple of suggestions I have to try to “quiet” things down.

  1. I believe @JeffL mentioned this previously, but the odrive/Google Drive iPhone/My Garmin folder is causing a lot of activity and also sees to have some sort of inconsistency in the odrive tracking. I would like to eliminate this variable by unsyncing that folder (right click->unsync on the “odrive/Google Drive iPhone/My Garmin” folder)

  2. After doing this, I would like to try unsyncing the xDrive/Invoices/USAA folder and then resyncing it, so see if the missing items now show up.

If the items still do not show up, please send another diagnostic so I can look at things after taking the above steps.


On trying to Unsync the My Garmin folder I got the error message “Can’t unsync My Garmin.” “Unexpected error. Please try again later.” After a reboot, and letting the restart sync finish, I tried again and got the same error.

On trying to Unsync the USAA folder, the context menu only has “No Options Available” Same is true up one level at xDrive. Only the root of the lined account has a populated context menu.

I mentioned this phenomenon earlier and it isn’t limited to this folder. Neither Sync nor Refresh at the linked account root enables the options further down the tree.

Hi @steve.davies.iphone,
Unfortunately I think you will need to reset the odrive cache on that computer, as @JeffL suggested last week. Can't get around - Waiting changes will auto retry

Please run through those steps to get everything into a known-good state.

Apologies for the inconvenience.


After selecting Deauthorize from the tray menu and acknowledging the dialog, the client takes 2-3 minutes to exit and then does not restart. After waiting for several minutes, I restarted the odrive client and the client is still authorized and starts to check sync status. Also, no new directory is created in the user home directory.

I restarted and odrive was still authorized. I tried the procedure again and got the same result.

Hi @steve.davies.iphone,
It looks like it may be best to do an uninstall and reinstall, then.

Take a look at these instructions: How do I uninstall odrive? for uninstall. This will do some of the same things as de-auth, including creating a backup of your odrive folder. Then install the latest version from here:

The re-install and re-sync are complete. Things seem to be working. I sent diagnostics again for reference.

Thanks for the help.

1 Like