Can't connect to SFTP

I’ve just set up a new virtual server, and even though I can connect through ssh and filezilla’s sftp, I can’t seem to get odrive’s sftp to work.

I’ve set it up with the following:
Type: Internet accessible sftp server (though I’ve tried both)
Host: (my server’s ip)
Start Path: /home/andy/odrive
Max Concurrent Connections: 3
Login with keyfile:
User: (my username)
Passphrase: (my passphrase)
Keyfile Content: (my private rsa key)

Hi @andrew.ault,
Can you tell me what error you are seeing? Are you able to link but not browse, or is an error being triggered on linking?

Hey Tony,

I’m able to link with no errors, but not browse. My app is telling me that all of my folders are not allowed, while the website tells me “Cannot browse (sftp connection name). That file or folder no longer exists.”

Hi @andrew.ault,
Interesting. Can you try a couple of things for me?

  1. Logout of the odrive web client, then login again. Take a screenshot of what you see and post here and then try to browse into the SFTP link again.

  2. Send a diagnostic from the odrive menu

Sure thing.

Immediately after logging in:

When trying to browse the folder:

I have sent my diagnostics.

Hi @andrew.ault,
It looks like we are able to connect just fine, but when trying to list the first folder the SFTP server is saying that the path doesn’t exist. Can you double-check the “start path” for the link and make sure that is correct? Try leaving that blank and see what happens, too.

That worked! I was under the assumption that I was pointing the link to its own folder, but making the directory on the server did the trick.


Great! Thanks for the follow-up.