Can no longer login to app, things going a bit crazy!

I’ve been running odrive on my macs for a couple of years now and have totally loved it.
I got a new Windows 10 machine and installed odrive as well. For some reason, it seemed to screw up a whole bunch of links within my odrive and I could no longer access files or folders from any mac.
I decided to follow the steps in the forums that you created for removing odrive as I thought that if I just re-install and relink to my Google Drive again, everything will re-sync and Ill be OK (everything appears to be fine on the Google Drive).
After uninstalling I then re-install but cannot go through the setup.
I receive the message ‘Login / Unable to connect. Please check your network connection’.
The network connection is fine and my VPN has been turned off.
The other strange thing I notice during setup is that the only service I can use to login in Google+, which is what I’d use anyway, but that’s odd.
Please help as I rely on this to work from all my computers!

Hi @daveharrison,
Are you able to see the right links and data when you use the odrive web client? ( I just want to make sure everything is as you expect from that perspective, first.

For the Windows machine, it sounds like you are having issues getting logged in.
Do you have any firewalls, proxies, or endpoint protection software running that could be interfering with odrive on that system?
Can you try sending a diagnostic from the odrive menu on that system so I can take a closer look?

Hi @Tony,

Logging in using Chrome on macOS, following occurs (notice the option only for Google): Issue resolved - removed link
The data doesn’t appear to be correct via the web client either.
I am unable to see the root folder called ‘Runnez’ on my odrive web-client, yet am able to see it without problem on my Google Drive. This was the folder that was part of the original issues with the windows machine.

On the Windows machine, I was logged in without any issue. I created a shortcut link and the whole thing went a little haywire! :slight_smile:
That folder and all its odrive links were no longer functionally on any of my macs.

The only thing running on the Windows machine, as it is all all the machines in the house, is ExpressVPN.

I uninstalled odrive from the windows machine, and one of the macs, when this issue appeared as I didn’t want anything to be deleted from my Google Drive.

Did you want me to reinstall on the Windows machine and do the diagnostic? (I can’t successfully login to the reinstall on macOS)

Is a possible fix just to destroy my odrive account and let me set it up again? (Although, it doesn’t stop the issue happening again it does let me work more efficiently again)

Hi @daveharrison,
It is hard for me to tell for certain, but it seems like you want to link two Google Drive accounts. Is that correct?

The login to odrive looks okay, but I think you will want to link the second Google Drive account so you will have 2 Google Drive accounts linked and 1 Facebook account when all is said and done.

To do that you can click on the “+ Link Storage” option and then select your Runnez account to link. Then you should see what you expect.

After that, let’s try installing odrive on your Windows system again and taking a look at what you see once you login.

For the sign-in options, we try to show you what you’ve used before to prevent confusion, but you can pick another service, if the ones displayed are not correct or you have multiple odrive accounts. To do this you will want to choose “Sign in as another user” on the odrive login screen.

Just to confirm, no, I don’t need the 2 Google drive accounts and have never tried to link the second one.

No, it’s just the usual link doesn’t have the correct links. Nor can I even install it on Mac OS X.

The Runnez folder that is missing is under my account and not the @runnnez account. I don’t use that for Google Drive at all - nor do I want it linked to my odrive.

Any other ideas?

Hi @daveharrison,
Thanks for the clarification.

On Mac, can you run the uninstall one-liner script to make sure everything is wiped out, then try to install again?

If odrive still doesn’t install, can you tell me what behavior you are seeing when trying to install and run it?

Would you also be able to show me a screenshot of what your Google Drive account shows in its root from the Google Drive web client and a screenshot of what it looks like from the odrive web client? I just want to make sure I am on the same page in terms of what you are seeing vs what is expected. You can message me directly if you do not want to post it here.

What is the best way to contact you privately?

OK @Tony , I ran that command and checked all the directories it references (including Application Support) and it appears to have worked.

I’ve created a new video to show you what happens during install. As you can see, I cannot start odrive successfully.

There is also no odrive folder in /application support either.

The Google Drive file list is here: Issue resolved - removed link

odrive web now gives me an error of “Cannot browse Google Drive. Google error.” with a semi-list of files and folders. This error only appears when I scroll down the page. This error is here:
Issue resolved - removed link

Issue resolved - removed link

Thanks @daveharrison.

For future reference, you can message me directly by clicking on my name and selecting “Message”.

Looking at the video, it seems like there is something preventing odrive from communicating with the backend during the login process.

I know you mentioned a VPN, which is currrently off, but do you have any other related services or apps running like a proxy, firewall, anti-virus, or other endpoint software that could be interfering with the odrive app connection?

Can you try sending a diagnostic from the odrive tray menu? We’ll see if it comes through, and if it does it may give us some additional details.

Can you also try running odrive from the terminal, just to see if anything is spitting out there?

  1. Open a terminal session (type “terminal” in Spotlight search):

  2. Run the following command in the terminal session (copy & paste + Enter):


    bindir=$(ls -d "$HOME/.odrive/bin/"*/ | tail -1); echo $bindir;"${bindir}"

Go through the login process again until it errors. The command will hopefully spit out some useful information to the terminal that we can use to troubleshoot this. Please copy and paste what it prints out here (if anything) so I can take a look.

Does your Windows 10 machine behave in the same way after installation, giving an error during a login attempt?

Glad to hear everything is working okay now @daveharrison!

I’m just making a note here for future reference and I’m going to remove some of the items in the previous posts since they are no longer needed.

The final issue on the Mac was due to Kapersky blocking some network communication to odrive endpoints.