Bug syncing files with leading space in file name

We are using Odrive to connect to our Mac server using FTP and Odrive. We have a few files that have a leading space in their name e.g. “ filename.doc” When you look at the placeholder for this file it appears with no leading space “filename.doc.cloud” and when you try and sync it it throws this error “Can’t sync filename.doc.cloud. You do not have sufficient permissions.” If I remove the leading space from the filename on the server it syncs fine.

Hi Robin,
Files and folders with leading spaces in them are not currently supported through the odrive FTP integration. Were you previously using another FTP client that was working with these files?

It sounds like you are using the built-in FTP server on OS X Server. Have you taken a look at using SFTP instead? This should support these leading spaces correctly on Mac clients. Windows doesn’t support leading spaces in file names, so keep that in mind as well.

For optimal compatibility, I would suggest removing the leading spaces in the file name.


Thanks for the reply Tony.

We’ve been able to access the files using Cyberduck.

You’re right we’re using the built-in-FTP server. We’ve tried using SFTP too, but have had issues restricting access to just the shared folders we want to grant access to.

It looks like my options are:

  1. Look at scripts to remove all leading spaces from filenames and folders (we have 700,000 files). I’ll look into this first.

  2. Look at 3rd party SFTP servers (e.g. CrushFTP or WingFTP). Have you had any experience/recommendations for using any with Odrive?



Thanks for the follow-up Robin.

To be honest, I haven’t played around much with SFTP on OS X, so I can’t offer much in the way of suggestions for managing access on that. Most of my testing and experimentation has been with OpenSSH and ProFTPD with the mod_sftp module on Linux, keying off the system users/groups for permissions.

Since it sounds like you have things setup the way you want, aside from the filename issue, I am hesitant to suggest a drastic change. A script to chop off the leading spaces on your files/folders is probably the easiest way to go. I imagine the only gotcha there will be duplicate names, if you have items that end up being the same name without the leading space. You can get around that, mostly, by using a substitute char like _ instead of simply removing the space.

Were the leading spaces put in intentionally? Was it to bring certain files to the top of a sorted list?

Thanks Tony.

It was to bring files to the top of the list. I wrote a script to replace the spaces with “_” and it’s working fine now.

I appreciate the update @robin.hoffmann. I’m glad to hear that things are working well now!