Blocked attempt to update remote file to 0 bytes (unintended?)


With the latest changes involving the “Not Allowed” syncs, I’ve been getting a bunch of files in there that I haven’t had before when syncing to gdrive and they all are:

Blocked attempt to update remote file to 0 bytes (unintended?)

Looking into the log file, all the files having issue are from the .git directory of a repo, specifically the reflog files that git will periodically empty out and set to 0 bytes.

I know I know, advice is to not sync a git repo across machines but I’ve been doing it for years – even pre-odrive – and never had a problem. Odrive has never had a problem either until about 2 weeks ago.

Hi @sauerc ,
This is an additional safety check we added recently to prevent updating a file to 0 bytes (you probably got that already :wink: )

In the vast majority of cases, this is not something a user would want to do, but if your workflow sees that this is often needed, you can disable this check: Advanced client options

If you don’t see that option in the odrive_user_general_conf.txt file, which is likely given that you are a longtime user, you can delete the current file and it will be automatically regenerated within a few seconds. If you have adjusted any parameters in there previously I recommend making a backup of the current file so that you can re-add any previous adjustments.

8 minutes from asked to answered!

I added allowZeroByteUpdate to the config file by hand, restarted odrive, and no more “Not Allowed”.

Thank you!

1 Like