Backup Sync Not Backing Up

I’m on a Linux Mint system, using the CLI. Now that I’ve figured out how to use it, it’s great.
I created a test folder, with five objects inside it, and a sub-directory with an object inside it as well, on the desktop and set it to back up to a remote folder using odrive. This was successful.

Then I set it to back up my system-backup folder, which uses rsync, located at /backintime. This backed up only the folder /backintime to the remote folder, and no sub folders. I restarted odrive, but no change. Running a status check, it reports that it’s idle, 1 mount point, 1 active backup folder, no active transfers.

Hi @mattzab,
The backup feature is pretty raw, as its a pre-beta version of backup that managed to slip out into the odrive Agent. It works, and there are folks out there using it, but it may have some quirks.

There is a backup log you can view. Maybe it can give us some additional details. If you installed the odrive agent via the instructions in our documentation, the log is in ~/.odrive-agent/log/backup.log. Can you take a look there and see what it says?

Hi @Tony,

I’m getting this ,
13 Jul 08:59:10AM INFO Beginning backup.
13 Jul 08:59:10AM INFO Finished backup.
13 Jul 09:59:10AM INFO Beginning backup.
13 Jul 09:59:10AM INFO Finished backup.

88 lines of that so far.

Error log is blank.
Agent log just has general info, nothing interesting/related.

Any thoughts?


New development:

I set my backup application to back up to a Google Drive folder that odrive syncs. So now the folder is within odrive’s normal view, without having odrive’s backup feature in place.

Still though, none of the files are syncing to the server, nothing is being sent, and the status is idle.

Here’s some stats on the folder, which may be part of the issue, though I’m not sure.

From Nemo File Manager’s Properties:
278,958 items, totalling 14.7 GB
(some contents unreadable)

Unfortunately, moving part of the files would not be a good option- if that were a possible solution I wouldn’t be able to take advantage of it.

Let me know what you think.


Hi @mattzab,
Don’t point the backup folder to the same folder that exists within odrive’s normal sync view. That could cause some problems.

For the folder being backed-up, what does the content look like in the root of that folder? Is it possible contains files/folders that have ignored names? See this section of the usage guide for more details:

Have you tried shutting down and restarting the odrive agent yet?

Hi @Tony,

I should have clarified ahead of time.

I’m testing this on two different machines. One the first machine, rsync copies my file system to /backup, in the root of my hdd, and I set it as a backup folder for odrive to sync to Google Drive.

On the second machine, rsync copies my file system to a Google Drive folder within odrive that I have synced.

Neither are syncing to Google. (They are going to different folders on drive)

I looked at the list of ignored names, and while there are likely some ignore names somewhere in there, the bulk of it would not be ignored names. None of it is syncing though.

Another note, I’m not sure if this is significant or not, but I use rsync as sudo/root. Do you think I should do a chown or chmod? Could that be preventing it from syncing?


Hi @mattzab,

This is a good point. Permissions issues could prevent access to odrive, depending on how things are setup. Which user is odrive running as? You could try this on a small set of files/folders to see if odrive can pick up the files when you open up the permissions on them.

Additionally, I was going to ask if you could experiment with a backup of a folder in your home directory, to see if things work better in a location where odrive definitely has full access to all of the data.

Hi @Tony,

I used chmod 777, chown myusername:myusername, and launched odrive with sudo. Still it only syncs one folder in.

I made another folder in my home directory called backintime for odrive to back up, with a sub-directory and a few files in there. Odrive is not backing those up either, and none of them are permission protected.

Odrive does still sync other files though, for example if I drop a zip file into Google Drive, it uploads pretty quickly.

Hi @mattzab,
This is definitely odd. I will need to carve out a bit of time to do some testing. The last tests I did were backing up deep structures just fine, and we haven’t changed anything since, so I’m not sure what’s up here.

As a side note, your folder name immediately popped Back to the Future into my head… not sure if that is what you were going for there. :wink:

I think it was a permissions issue. I had stuff owned by root, and odrive was running as user. I’ve changed the way I do backups and I’m now testing a backup of my home folder only with the user account. I’ll report back if it syncs correctly. (I’m copying the files directly to a folder within odrive’s view)

Thanks for the follow-up @mattzab. I was able to do some testing yesterday and I was seeing expected behavior, so there doesn’t seem to be something generally broken. At least, nothing obvious.


How can I run odrive as root?

I tried sudo nohup "$HOME/.odrive-agent/bin/odriveagent">/dev/null& but that doesn’t seem to produce the effect I’m aiming for. I figure, if I can run odrive sync agent as root, then my system backup snapshots that I’m creating (with root) will back up correctly with odrive.

Does this seem like the best idea?

Hi @mattzab,
That should work. Try sudoing to a root shell, then running odrive.
sudo su -