Backup from PC to Amazon Cloud Drive

I’m trying to do something simple: I’d like to back up various folders from my PC to Amazon Cloud Drive, and anytime I add a folder or file on my PC, I want it automatically synced to Amazon. I thought this was how odrive worked, but I’m having a lot of trouble getting this simple use case to work correctly.

For example, I’ve right-clicked my ‘Pictures’ folder on my PC (Windows 10) and selected ‘sync’. This worked fine at first, but new folders added to a subdirectory under Pictures doesn’t show up under my odrive folder, won’t sync to Amazon, and I can’t seem to find a way to add it manually (nor do I want to; I just want any new files/folders added anywhere under Pictures to automatically get picked up and synced to Amazon. If I right-click the missing folder and select ‘Sync’, it says the folder’s already an odrive folder; but it never shows up in Amazon and there’s no .cloudf file for the new directory – only the directories that existed when I first synced the ‘Pictures’ folder.

I thought I might try deleting the Pictures placeholder out of my odrive folder and re-adding it, but then I get warned it’ll delete my source files, which I assume means off my local PC, which I definitely don’t want.

Can you help me with this basic use case? I simply want to mirror what’s on my PC to Amazon, and I never want to put the local PC files at risk of being deleted. Thanks in advance – Dave

Hi @david.staas,
Yes, if you have used “sync to odrive” on your Pictures folder, it should sync everything inside automatically.

Is odrive syncing, currently? Is it possible it is still int eh process of uploading files/folders and hasn’t gotten to your new folder yet?
Is there anything listed in “not allowed”, “waiting”, or syncing in the odrive menu?

Please send over a diagnostic from the odrive menu and I’ll take a look.

Hi Tony, thank you for the reply. Here’s a few screenshots showing the problem:

Here’s the source directory on my PC. Notice the ‘2012’ and ‘2017’ directories:

Here’s my odrive dir. Notice the 2012 and 2017 stubs are missing, and I can’t find a way to manually add them:

(Will add the other 2 links in the next reply, forum limits me to 2 links per post)

As you can see, those 2 directories are missing and I can’t find a way to get them to sync. I have not exhaustively searched all my photos, so I’m concerned there may be many more missing directories that haven’t been synced.

I’ll go generate diagnostics right now. Thank you for your help, I appreciate it! – Dave

Here’s my Amazon drive. Notice 2012 and 2017 are missing:

There’s no sync active, here’s the odrive menu:

Hi @david.staas,
In the diagnostic you sent, I do not see any “sync to odrive” folders defined. I believe you are trying to sync content on a different drive (S:), but I don’t see any folders that odrive knows about there. When you click on “sync to odrive” in the odrive menu, is anything listed? If not, then that is the reason why things aren’t syncing.

It appears that at one point it was setup this way. Did you ever uninstall and reinstall odrive, or was there a point where your trial ran out but before you converted to Premium? If so, the “sync to odrive” folders would’ve been disassociated at that point and the relationship would need to be recreated.

Hi Tony, you’re right, ‘Sync to odrive’ is empty. When I go to S:\users\dstaas\Pictures and click ‘sync to odrive’, I get handed off correctly to select the destination folder, but it still won’t sync – the ‘sync to odrive’ item now says ‘Open Pictures Folder [invalid]’. I’ll generate another diagnostics. Thanks for sticking with me – Dave

Hi @david.staas,
A permissions error is being generated when odrive is trying to access the drive.

Let’s try this:

  1. Right-click on “S:\users\dstaas\Pictures” and select “remove sync”
  2. Look in the “S:\users\dstaas\Pictures” folder and see if there is a “.odrive” file in there. It is a hidden file, so you will need to enable viewing hidden files In Explorer. You can find the option under the “View” tab at the top. Check the “Hidden items” box. If you see the .odrive file, delete it.
  3. Right-click on the “S:\users\dstaas\Pictures” folder again and select “sync to odrive” Set up the folder as it was before.

If you still get an error, make sure that the S: drive is writable, as odrive needs to be able to write to it.