Amazon Upload Failure

I’m having trouble uploading to Amazon.

I keep getting this error: - Error: code CD_NETWORK_DOWN caused by CloudDriveNetworkException(code CD_NETWORK_DOWN - (‘The write operation timed out’,) caused by ConnectionError((‘The write operation timed out’,)))

Any help is appreciate.

Hi @kristinaleist,
Are these large files?

Can you send a diagnostic from the odrive tray menu?

Thank you. I am sending now.

They are large files - videos.

Hi @kristinaleist,
This is an pretty rare error to see. It can be a symptom of an unstable or slow internet connection, or the result on an application on the computer that is interfering with the network traffic.

I have been doing some testing and uploading several large files (up to 8GB in size) and I haven’t encountered any issues yet.

  • Can you tell me how fast your internet connection is?
  • If your network connection pretty stable?
  • Do you possibly have any software running on the system that is monitoring or restricting network activity? The last time this was reported, the culprit ended up being a program called “NetWorx”, for example.

Internet has been very stable for us. I have very few programs loaded as I just built this computer - Windows 10 OS, Cannon printer software, Microsoft Money Plus and some software that came with my motherboard . I do have Windows Security including the Firewall & network protection running.

Thanks @kristinaleist.

Did you ever run into these issues, previously, or is this a new development on this new system?

Let’s try tweaking the upload settings to see if we can mitigate the issue:

  1. Double-click to open up the “odrive_user_premium_conf.txt” file in the root of the odrive folder (C:\Users\krist\odrive\odrive_user_premium_conf.txt)
  2. Change "maxConcurrentJobs": 4, to "maxConcurrentJobs": 1,
  3. Change "maxConcurrentUploads": 4, to "maxConcurrentUploads": 1,
  4. Save the file

This will limit the number of simultaneous uploads and may help to prevent the error you are seeing.

I have never had problems like this before. I’ve never split large files in the past or had to limit speeds. I have had some files go through now that I set the split large files to 1 GB, but still have a lot of them failing to upload. I am going to try your configuration settings tonight. I’ll let you know how that goes tomorrow night.

Hi @kristinaleist,
I also suggest turning off file splitting, since it ends up saving the files in a special format that may not be desirable for your needs.

1 Like

Okay. Thank you. I’ve never turned it on before, because I had a back up service that split files (no choice) and I ended up with a lot of corrupted files.

Hi @kristinaleist,
I just wanted to follow-up and see if those settings helped with your larger uploads.