Amazon CloudDrive - uploading a 6 GB file


#1

Trying to upload a file to Amazon CloudDrive - it’s a 6 GB file, and ODrive keeps going back to the beginning once it’s done uploading.
Is there a file size limit?
ODrive for Mac - prod 6497


#2

Hi @budowski,
Amazon Drive has a history of having issues with large file uploads via their API where they will return a timeout error on upload, but eventually process the file. The problem is that it shows up late enough that odrive doesn’t see it before attempting a new upload.

The next time this happens can you send a diagnostic from the odrive menu so we can take a closer look?

Also, once it reaches 100% and then retries, can you try exiting odrive, waiting 10 minutes, and then checking the Amazon Drive web client to see if it actually appears?


#3

I’ve sent the diagnostics right now.
Tried doing what you’ve suggested, didn’t help…
I can’t exactly catch it right after it finishes uploading since it takes many hours every time.


#4

Hi @budowski,
Taking a look at the diagnostic, Amazon just seems to stop responding when waiting for confirmation of the upload. The I wonder if it is running into an issue with the name, but is breaking at their service level and is not able to return a proper error.

Can you try renaming that file to a simple name and see if that makes any difference. If not, please send another diagnostic so I can see if there is any difference in the return.


#5

Thanks - I’ll rename it to aaa.mp4 and retry


#6

Renaming did not help - went back to 0%.
I sent out diagnostic logs.


#7

Hi @budowski,
Unfortunately the diagnostic didn’t seem to come through.

Can you try sending one more time?
Can you also tell me what the new name of the file is?


#8

Sent it again - it’s named aaa.mp4


#9

Hi @budowski,
This diagnostic only shows one attempt for an upload, but it looks like it was stopped via a user action. Did you happen to stop it after waiting a while?

Can you tell how long it seems to sit at 100% before going into waiting?

In the previous diagnostics it was basically that Amazon was not returning a response after the upload was done. It is possible that we can extend our timeout to allow more time, although I think we already wait 5 minutes after all bytes are uploaded.

Can you try moving this file from the odrive folder to a temporary location and then uploading it via the Amazon web client to the same location? I have seen sometimes where the Amazon API will not correctly process a file, but their web client will. If that works, you can move the file back into the odrive folder in that location and odrive should see it as synced. That may at least allow you to move past this.


#10
  1. I stopped it via user action after it reached 100%, restarted at 0% and continued.
  2. Web client - if it’s the Amazon drive web client - it doesn’t allow uploading the file (getting a “file too large” error).

#11

Hi @budowski,
Let’s try an alternate approach and see if it works.

Can you create an odrive Space for that folder that you are uploading to and then try to upload the file there?

  • Go to: https://www.odrive.com/account/myodrive?catid=spaces
  • Click on + Share Storage
  • Name your Space and select your Amazon Drive folder as the target. You can leave the Members section blank.
  • Click Share
  • Go to your desktop client and open the Spaces folder (it may be a placeholder so it will be named Spaces.cloudf)
  • You should see the Shared Space you just created there.
  • Try to upload the files that are giving you trouble here and see if you experience the same issue.

With Spaces the file upload is routed through our odrive proxy servers, which can end up providing a faster and more stable connect to your storage. I am wondering if the problem persists this way.


#12

Managed to upload!!!
What I did:
Moved the file to a temp folder, let odrive discover the file is missing and finish syncing.
Then close odrive, wait a little, and reopen.
Rename the file to bbb.mp4 -> move it back to the synced folder -> odrive uploads it successfully


#13

Thanks for the update @budowski! I’m glad you got it up.

Unfortunately I am still not clear on the root cause of the issue. When I was looking at it previously the upload to Amazon was ending up timing out waiting for a response from them. If you hit this again, just ping this thread and we can try to investigate further.