After updating Catalina odrive not contining when clicking "Get Started" button

Tony, i have similar problem with Catalina Version 10.15.4. Odrive was working just fine before the OS update few days ago. After the update, it pops up “lets start” dialog box and when you click on the blue button, dialog box goes away and nothing happens. I tried to reinstall Odrive (latest version), tried to issue commands posted above by @alex, but still can’t get it working. Is there anything else i can try?


Hi @deo,
This sounds like a different issue than the previous post, so I created a new thread for it.

Just to be clear, are you seeing this pop-up?

If so, this will pop-up when you need to login to odrive. When clicking on the “Get Started” button a new browser window should open up. Since you just went through a MacOS update, it sounds like the update may have changed something and has created two issues.

  1. odrive thinks that it is running for the first time
  2. odrive cannot open the browser to allow you to login

First, can you confirm that the above window is what you are seeing when running odrive?

If so, this part of the login process is essentially running the following command to pop the web browser:
echo 'open location ""' | osascript

If you open a terminal window, copy and paste that command in, and then hit return, does anything happen or print out?

Thanks for your response, @Tony

  1. I confirm that the above screen print represents the right dialog box
  2. The command you sent, opens up login scree and allows to login.
    Everything is working now.
    Thank you!

Hi @deo,

Great! Thanks for the update.

I just want to confirm that you are all logged-in to the odrive desktop client now. The command I listed was more of a “test” command, so I wasn’t sure if it would actually provide resolution for your specific problem.