When should tick mark show on files?


Just wondering when the tick mark is supposed to show next to files folders?

After uploading a few thousand files to an encrypted amazon cloud drive folder, the tick marks no longer show for any files or folders across my google drive or amazon accounts.

Have tried refreshing & resyncing. Odrive menu icon is black rather than pink now. Not sure whether this is intended behaviour and ticks are only supposed to show shortly after syncing?

Mac OS 10.12.2.

Hi @Jon_V,
They should show if the files/folders are in sync and do not have any files that still need to be uploaded or are in the process of uploading. Do you see anything listed in the odrive tray menu actively syncing or in “waiting” or “not allowed”?

No, nothing remaining to sync and couldn’t get the marks to reapply, even after rebooting.

Tried to reset things by de-authorising and logging back in.

That didn’t help so I moved the odrive folder to a new location (using the app’s facility for this). The old location remained so I changed the location back to the original and deleted the new location (which was unpopulatd except for .cloud(f) files).

Sync / tick marks are showing for unencrypted content, but all ~40 gigs of encrypted content is being re-uploaded :frowning:

Hi @Jon_V,
Deauthorizing will clear out odrive’s “memory”. With encryption, this means that you will end up re-uploading data if you re-add the files after wiping that “memory”. There is some additional details on that in this thread here:

Are you seeing the overlays for the encrypted content now?

All ticks showing for now thanks.

What steps should I take if they disappear again?

Hi @Jon_V,
In periods of activity on a larger structure you can see this type of behavior, but it should be temporary.

Toggling the Finder extensions is also something to try:
You can find the option under System Preferences -> Extensions. odrive is listed under “Finder”. Unchecking and then checking the odrive listing may help to return the overlays.

Other than that, a Finder restart or a system restart can be tried.

1 Like

Still having ongoing issues with this…

I have an encryptor folder with amazon cloud drive and google drive mounts in. 132GB combined, ~2300 files.

After a reboot, the tick marks do not show. Odrive hammers the CPU for a bit (~5 mins total CPU time reported in activity monitor). After this, tick marks still do not show. Relaunching finder then shows the marks for the containing folders (encryptor folder and the amazon / google mountpoints) but not the sub files and folders - see image.

Given the marks are the only indication that things are synced, this is making it hard to have much confidence in what odrive is doing.

1 Like

Since the parent folder shows synced, it should be an indication that there are no things underneath that still need to be synced. I am not sure why the underlying folders are not showing the same thing, though.

Was/is there any activity shown when clicking on the odrive menu bar icon?
To your knowledge is odrive idle now?
I am not able to reproduce this on my own systems, so I am wondering if there could be some conflicting application. Do you have any other applications that are adding icons to Finder? You can see this under System Preferences -> Extensions->Finder.

The next major release will have some adjustment in the overlay behavior that may address the problem you are seeing, too.

1 Like

Odrive is idle, yes

When things are in this state, clicking refresh on a folder Seems to make the ticks appear on parent folders or child files but not the actual folder - at least immediately.

Generally the marks can be made to appear with repeated refreshing and finder relaunches etc, until the next reboot.

There are no other finder extensions active.

1 Like

I’ve just noticed (by turning on display of hidden files in finder) that there are some hidden and unticked files in a directory which itself has a tick on it.

I will experiment with removing all of these to see if it resolves the problem.

1 Like

I’ve just noticed (by turning on display of hidden files in finder) that there are some hidden and unticked files in a directory which itself has a tick on it.

I will experiment with removing all of these to see if it resolves the problem.

I’ve had a play with this and removing the hidden files (some temp files ‘$’, some with ‘.’, both normally hidden by finder) definitely seems to have helped.

Less odrive CPU time on startup and tick marks showing as they should. May be worth looking at the program’s handling on these files?

1 Like

Thanks @Jon_V,
The blacklisting/ignore filtering piece is in the process of being overhauled as part of our next major release, so that work may resolve what you were seeing here. I will make a note of your experiences for the QA cycles.

Are you able to provide a few specific folder/file names that were in those folders?

1 Like

Sounds good.

I think the files causing an issue were named $somefilename.xlsx - recovery files created by ms office 2016 or libreoffice.

I’m not sure what it is that causes finder to treat these as hidden - whether it uses filename or extended attributes for this.


Thanks for the follow-up and specifics @Jon_V!

1 Like