Unable to sync .cloudf folder on linux agent

I tried to setup the linux agent following the “usage guide” I found on the website. I installed and authenticated the agent. I created the odrive folder and created the agent mount. However when I attempted to sync the Dropbox folder with the command
"$HOME/.odrive-agent/bin/odrive" sync "$HOME/odrive-agent-mount/Dropbox.cloudf"
I obtained the message
Unable to sync Dropbox.cloudf. This file doesn’t exist.

The same applied to the attempt to sync the GoogleDrive folder.

Did I miss anything?

Hi,
Can you tell me what you see when you do a listing of the odrive mount folder?
ls -al "$HOME/odrive-agent-mount/"

Thanks!

at first there was only a GoogleDrive.cloudf file. Then I went on the odrive web app and I selected also dropbox to be syncronized. Nothing changed on the odrive agent mount folder. I this point I created a blank Dropbox.cloudf file. However I receive a “file do not exist” message when I attempt to syncronize either the Dropbox.cloudf file or the original GoogleDrive.cloudf file. Finally a .odrive file appeared on the mount directory (or something similar, I am not at that computer now)

Hi,
Yes you will need to link the accounts you want access to. It sounds like you signed-up for odrive using your Google account, which is why that .cloudf file exists. Once the accounts you want are linked you will want to issue a:
"$HOME/.odrive-agent/bin/odrive" refresh "$HOME/odrive-agent-mount/"

To refresh the new changes, at which point you should see them in the folder and should be able to sync them using the sync command. Make sure you do not create placeholder files yourself.

If you are still seeing issues after that, it may be best to start over by removing the “$HOME/.odrive-agent” and “$HOME/odrive-agent-mount” directories and following the install and setup instructions again.

I attempted to refresh but I received the message that the Agent was not running.
I decided to start from scratch and I did.
However, now I receive these messages:
zorin@ZorinPC:~$ “$HOME/.odrive-agent/bin/odrive” sync "$HOME/odrive-agent-mount/Dropbox.cloudf"
Unable to sync Dropbox.cloudf. Please check your network connection or manage your proxy settings.
zorin@ZorinPC:~$ “$HOME/.odrive-agent/bin/odrive” sync "$HOME/odrive-agent-mount/GoogleDrive.cloudf"
Unable to sync GoogleDrive.cloudf. This file doesn’t exist.

In my odrive.mount.folder now I find both the GoogleDrive.cloudf and the Dropbox.cloudf files, I also find a .odrive file

Can you copy and paste the output from these commands?
"$HOME/.odrive-agent/bin/odrive" status

"$HOME/.odrive-agent/bin/odrive" status --mounts

ls -al "$HOME/odrive-agent-mount/"

“$HOME/.odrive-agent/bin/odrive” status

odrive Make Cloud Storage THE WAY IT SHOULD BE.

isActivated: True hasSession: True
email: fc.campanile@gmail.com accountType: Google
syncEnabled: True version: 678
placeholderThreshold: neverDownload autoUnsyncThreshold: never
downloadThrottlingThreshold: unlimited uploadThrottlingThreshold: normal
autoTrashThreshold: never Mounts: 1
xlThreshold: never Backups: 0

Sync Requests: 0
Background Requests: 0
Uploads: 0
Downloads: 0
Trash: 0
Waiting: 0
Not Allowed: 0

“$HOME/.odrive-agent/bin/odrive” status --mounts

/home/zorin/odrive-agent-mount status:Active
status:None

ls -al "$HOME/odrive-agent-mount/"
totale 12
drwxrwxr-x 2 zorin zorin 4096 lug 29 08:27 .
drwxr-xr-x 56 zorin zorin 4096 lug 29 08:27 …
-rw-rw-r-- 1 zorin zorin 0 lug 29 08:27 Dropbox.cloudf
-rw-rw-r-- 1 zorin zorin 0 lug 29 08:27 Google Drive.cloudf
-rw-rw-r-- 1 zorin zorin 71 lug 29 08:27 .odrive

Hi,
The Google Drive .cloudf has a space in it, which would explain the error you are seeing there. Try this command instead for Google:
"$HOME/.odrive-agent/bin/odrive" sync “$HOME/odrive-agent-mount/Google Drive.cloudf”

The Dropbox error indicates that odrive is having an issue reaching Dropbox. Are you using any firewalls or proxies that could be interfering with the connection?

Thanks!