Sync External Hard Drive to Amazon Drive using odrive

Hello,

I have an external hard drive that connected via USB to my desktop. It has my collection of pictures, music, and videos. I want to sync this external hard drive to my Amazon drive using odrive. This means that any time I add a picture to the external hard drive folders, it will automatically backup to my Amazon drive. I tried right clicking a folder in my external hard drive and selecting ‘Sync to odrive’ - the folder was created in my Amazon Cloud drive. However, it says that the folder is empty (on Amazon Drive), and no files are being sync’ed - even though there are files in the original folder on the external hard drive. Am I missing something in the process?

I checked the knowledgebase of other threads and didn’t see this issue before, so I apologize if it has already been covered.

Thanks in advance for your time and expertise!

This seems pretty strange since it sounds like you have followed the steps as expected. To investigate the problem we need further information, would you like to share the below details?

  1. Can you navigate back into your external hard drive folder again and confirm the right-click option “Remove Sync” is available.

  2. Can you confirm, there is entry created in odrive menu under “Sync to odrive”

  3. If answer for #1 or #2 is no then this means somehow folder is not correctly mounted to odrive and you should try “Sync to odrive” again.

4a. If answer for #1 and #2 is yes then try adding a test file “odriveTestFile.txt” into your external hard drive folder and check if it syncs to Amazon. Also add a test file “amazonTestFile.txt” using Amazon web client and see if it syncs file to your local machine external HDD.

4b. Send Diagnostic report from tray menu and let us know your OS username and timestamp. I’ll look into it

Thanks,
Asif

1 Like

Hey Asif, I appreciate your help. The following is what I tried out.

  1. Remove sync was not available. But it did have the option to Sync to odrive. So I tried to Sync to odrive. However the folder path was already created so I deleted the original and synced again. However even after deletion it still said the odrive folder already existed. I then emptied trash and deleted all syncs. But when I tried to Sync to odrive it still said there was already a folder there.
    So I tried with a new folder. The folder almost immediately had the blue check to say sync was done. But the folder was empty, just like the previous folder I had tried. I checked and it still had the option to Sync to odrive.

  2. I checked this option. My folder showed up in “Sync to odrive” but it had “invalid” in brackets next to the name.

  3. Mutiple tries of sync to odrive have been unsuccessful. It says there is already an odrive folder.

4a. The odriveTestFile.txt did not upload to amazon .
The amazonTestFile.txt did not show up in the external hard drive folder.

4b. User name is jpetersuf and I sent in diagnostics at 9:12pm EST on 2/27/17

Thank you and I look forward to hearing from you.

I have looked at the diagnostic report and it seems like folders are failing to sync due to mount is raising illegal path exception. I would not determine the reason since visually I cannot detect any issue with the folder names / paths (for example: E:/Action Shows is legal name in Windows OS)

Would you please goto odrive tray menu, open “Sync to odrive” and click on “Open Your Folder Name [Invalid]” and confirm the error message it gives (please post the snapshot of the error here).

Also can you confirm there is no illegal chars with the folder names you are trying to “Sync to odrive” and you have full access (write / read) to your external HDD. Btw, you can remove the invalid mounts from odrive tray menu by clicking on them and selecting Remove Sync.

Thanks,
Asif

Our engineering team has further looked into the matter and suspected that the external hard drive file system somehow preventing our tracker file to be written / read from the volume.

Would you please confirm the external hard drive file system and does it allow you to create .odrive file (https://www.odrive.com/s/abdec91b-d420-4a15-b1b8-1cb25eca3ce0-58b54b75) without any issue?

Thanks,
Asif

first repy:
I attached the image of the error I get when trying to open folder via “Sync to odrive” in tray menu.

I can confirm you are correct and there are no illegal characters in the folder names.
What is the best way to confirm permissions? In the Security tab it looks as though “Everyone” has all read/write permissions except for “special permissions”

second reply:
What do you mean by “does it allow me to create .odrive file”? How should I test creating that file? Do I just Right Click>Save As with that file to a folder in the external? Or save and move that file to external?

Thanks

Unfortunately provided error suggests that your external HDD is not allowing app to read / write files or at-least not permitting file name with leading dot (for example: our mount tracker file .odrive)

  • Do you have another USB / HDD? is this behavior consistent across all storage devices or specific to just this particular device.

  • You can run test by copying .odrive to your external HDD (just right-click --> Save As with that file to a folder in the external) and also check if it allows you to open the file in notepad directly from the external HDD.

Thanks,
Asif

Asif,

I don’t know what changed, but the newest folder we have been working on (Taxes 2011) now appears in my Amazon Cloud Drive and contains the files that are on my external hard drive. Success! Great job and thanks for your help and prompt responses during this troubleshooting process.

To answer your question, it does allow me to save, but it looks like it changes the name to “odrive.html” instead of being “.odrive” - it does allow me to open it via Notepad. Alternatively I tried to create a file named “.odrive.txt” and it allowed me to create the file without error.

Thanks again for your help. One additional question - the feature to sync external hard drive only comes with the premium version of odrive, correct?

1 Like

Great! I’m glad it is all sorted out.

Yes that’s correct, “Sync to odrive” is premium plan feature.

If you are interested, here is list of all benefits user gets after upgrading to premium package and experiences more controlled and advanced sync capabilities.

Thanks,
Asif

1 Like

Hello,
I’m on mac os x High sierra, premium plan feature of odrive.
When i right click on a folder accessed via SMB, i dont have “Sync to odrive” feature.

how come?

I have the feature only for external folder located physically on my computer.

Hi @litemails,
Can you take a screenshot of what you are seeing?

In order to use sync to odrive on a network share, it will need to be mounted under a local folder like /Volumes and you will need to be right-clicking on a folder inside that mount. For example, /Volumes/MyNetworkShare/MyFoldertoSync