SFTP Error on oDrive Client

Hello. Just recently we have been experiencing an issue where the User client will not expand folders, and it gives a “SFTP Error”. I don’t have any other information than this, but if I restart the oDrive client, it will work again for a small period of time before giving the error again.

This is happening for multiple users on connected to our SFTP server
We have restarted the SFTP server, and even updated to the newest software. We are using WingFTP.

Nothing has really changed, and this has happened all of the sudden. Has there been any recent updates to oDrive?

Hi @wh33ln,
There haven’t been any updates to odrive recently.

This happens to multiple users at the same time, or randomly for each user? Can you send a diagnostic the next time you see it and I will see if there is anything I can find?

Multiple at the same time. I just now generated the error and sent a diagnostics.

Hi @wh33ln,
I see several “SFTP_TOO_MANY_SIMULTANEOUS_CONNECTIONS” exceptions. This can indicate that your connection limit is set too low (in your link settings) for the actions you are trying to take.

It could also indicate that the server is limiting total connections.

Yes, I am aware our server is limiting connections… Usually we get an error that says “too many connections” if that was the case.

Are you able to tell if this is the reason we get the latest error that just says “SFTP error” ?

Hi @wh33ln,
I took another look and I also see a number of “Server connection dropped” exceptions, in addition to “too many simultaneous connections”. These are the only 2 types of exceptions I see.

The “server connection dropped” exception is likely the one that is triggering the generic “SFTP Error”, if you are also seeing a separate “too many connections” error.

Do you see anything in the FTP server logs? http://www.wftpserver.com/help/ftpserver/index.html?system_log_setting.htm

Hey Tony,
I have adjusted the connection limit on the client (I have several users that I have adjusted). Within the client connection setup the SFTP limit maxes out at 20, and I had it at 10 before. Users still get that error coming up. I just sent a diagnostics from one of the users about 5 minutes ago.

On the server logs I can see a few errors, but I don’t know if they are from that same user. The error log says:
Connected from xx.xx.xx.xx (local address xx.xx.xx.xx, port xx)
Failed to exchange the keys
closed connection, disconnected from xx.xx.xx.xx

Hi @wh33ln,
I took a look at the diagnostic, but I actually don’t see any errors in it. It looks like they may have just restarted the client, which may be the reason.

What actions are being taken when the errors occur?
How many users do you have using this SFTP server?
How often are these errors coming up?

If I have them restart the app, it will work for a short period and let them expand folders around before popping up again.

I have about 15 users, and I am hearing complains from almost all of them. Which is odd because we have been just fine for quite some time.

Just now sent another diagnostic from another user, after having them reproduce the error

Resolved. WingFTP had to push out an update to their server app.
Thanks for the help

Great! Any idea what the issue was? My guess was that the server was holding on to connections that should’ve been closed.

Well, we are using the SFTP protocol, and the release note to the update said it included a fix to the “Failed to exchange the keys” error, which as I mentioned above is one of the errors I was seeing on the server. So far the update has fixed it.

Thanks for your quick response and help. oDrive is great.

1 Like

Great! Thanks for the additional details.