Running Odrive makes internet unusable

I have been using Odrive for a year or so and really like it. For the past month or two, whenever I open up Odrive on my Mac Mini, it makes the internet unusable on any other device including my Mac Mini. The files appear to sync but everything else times out or takes a very long time to load. If I close Odrive, everything goes back to normal.

When I run speed test when I am not running Odrive, I average 45 mbps down and 5 mbps up so I don’t think it is a bandwidth issue. Also, I used to run Odrive all the time and there were no issues. I didn’t report this issue right away since I was hoping a new version of the application would come out that fixed this issue but so far the issue persists.

Do you have any suggestions on what to do next or what information do you need from me to further troubleshoot this issue?



One other thing to add. I run Odrive on another Mac on the same network and it doesn’t cause this issue when it is syncing. It appears to be isolated to my Mac Mini computer.



Do you normally have odrive off and then you start it up and experience this issue?
It is only when files are uploading?
Can you tell me a little bit more about your typical use of odrive and how it factors in to what you are seeing?



I used to have odrive running all the time but then a month or so ago I wasn’t able to use the internet reliably. At first I thought it was an issue with my ISP or router but after troubleshooting the issue extensively I found that everything went back to normal when I closed Odrive on my Mac Mini. When I start it up again, it kills my internet connection so I now run it sparingly when I know I won’t be at my house.

My Mac Mini is a media server so odrive is typically uploading large video/audio files (typically 200 mb-2 gigs per file) to One Drive and/or Amazon Cloud Drive. I use the encryption service in odrive for all of these files. I use odrive as a backup service in case one of my hard drives fails but I don’t use the unsync option since I want to have all of these files locally as well.

Most of the time this only happens when files are actively syncing. Since I haven’t been running it much recently, there is a backlog and so sometimes I will stop the syncing in odrive instead of closing the application entirely and that normally fixes the issue. This doesn’t always work though and many times when it has been running for 12 hours +, I end up having to close the application entirely because stopping the sync within the application itself doesn’t seem always resolve the issue.

Hope this gives you some more information to work off of.



Hmm. It is possible that you’ve reaching a tipping point for performance impact by incrementally adding items, over time. Do you know how many items are currently being tracked now?

Since it sounds like you are using odrive mostly for backup instead of bi-di sync, our upcoming backup feature may be better suited for your use case.

In the meantime, there may be things we can do to alleviate the impact by disabling Finder Extensions (it doesn’t sound like you are really using them), which can reduce some overhead. You could also make use of our CLI to manage sync more granularly, and turn on odrive at specific times.

When you see this impact next, can you send a diagnostic from the odrive tray menu and run this command from the terminal, pasting the results here?
ps -eo rss,%cpu,command | awk '{ hr=$1/1024 ; printf("%12.2fMB ",hr) } { for ( x=2 ; x<=NF ; x++ ) { printf("%s ",$x) } print "" }' | grep "[o]drive"


I reinstalled odrive yesterday to see if that would fix the issue and everything worked great for 6+ hours. I was able to use the internet on all of my devices on my network and odrive was syncing normally. When I got up this morning, I couldn’t access the internet on any of my devices again. I sent in a diagnostic report but I can’t tell if it got to you since nothing was working except for the sync. Also, I did not have this page up on my Mac Mini computer so I wasn’t able to run the commands in terminal since I couldn’t access the internet. It looks like these commands are related to the CPU usage of odrive and I monitored this for a couple of minutes and I didn’t notice it jump above 4% CPU utilization.

I also checked my traffic monitor on my router while this was happening and odrive was consistently uploading at a rate of 800 kb/s and downloading around 5 kb/s. This was the only actively on my router at this time even though I was trying to load web pages on other devices. The error that would appear in Chrome after the page tried to load for a couple minutes is DNS_PROBE_FINISHED_NO_INTERNET.

The odrive folder on my Mac Mini computer is 1.15 TB in size and contains 8,886 files.

I will more than likely switch to your backup solution once this is released. Is this something that is coming out soon?

After I closed odrive, everything went back to normal. Hopefully you received the diagnostic report report and can figure out something related to this.



Hmm… it appears that our default method of throttling doesn’t work well enough within your configuration.

Since you are on OS X we can use some built-in methods from the OS X terminal for throttling traffic to see if that works better for you. Warning: The stuff ahead is a bit more advanced

This command uses packet filtering + traffic shaping to limit traffic to 6Mb/sec on port 443 (communication to ACD and OneDrive will be over port 443).

sudo pfctl -E;(cat /etc/pf.conf && echo "dummynet-anchor \"odrive\"" && echo "anchor \"odrive\"") | sudo pfctl -f -;echo "dummynet out quick proto tcp from any to any port 443 pipe 1" | sudo pfctl -a odrive -f -;sudo dnctl pipe 1 config bw 6Mbit/s

If you want to adjust the rate after setting it with the above command:

sudo dnctl pipe 1 config bw [desired number here]Mbit/s

To reset things use this command:

sudo dnctl flush;sudo pfctl -f /etc/pf.conf

An easy way to monitor the traffic from odrive is using nettop:


Once nettop is running, hit ‘c’ to collapse the view and ‘d’ to show the delta (which will give you a nice view of the rate per second per process). Look for ‘odriveapp’

I tested this on my own system just now and it seems to work fairly well.

Thanks! I’ll try this out when it starts acting up again.



Wanted to give you an update. After I saw this post I looked at the error messages for the files that ended up in the “Not Allowed” menu in the odrive app. I ignored this section previously since there were some items in there that exceeded the file name length for OneDrive and assumed that all of the files were in there for this reason. After looking at the errors, some of them were there because odrive said I wasn’t logged into OneDrive. The strange thing is, I was able to create a new folder in OneDrive via the odrive web app and I verified that odrive still has full API access to my OneDrive account. The other odd thing is that the files appear to upload to OneDrive and then once they get to 100% synced according to the app, they end up in the “Not Allowed” menu with this error.

I ended up moving all of these files to my Amazon Cloud Drive folder and they uploaded without any issues. My working theory at this point is that something goes really wrong once odrive receives a critical mass of these errors from OneDrive. So far, odrive has been running without any issues over the past couple days once I moved everything over to Amazon Cloud Drive. I’m happy keeping these files on Amazon Cloud Drive since I have unlimited space with them. I was using OneDrive for the heck of it just to see how things worked with multiple cloud accounts.

Thanks for your help and let me know if it would help to send another diagnostic report your way.


Interesting. To clarify, you believe that the internet congestion correlates to these OneDrive session errors you were seeing occasionally?

OneDrive has a bit of a funky flow for session validation during upload. We are actually taking a look at how we can optimize our process to work with their behavior better.

Let me know if you see any more of the congestion issues now that you are primarily using Amazon Drive.


6 posts were split to a new topic: Issues syncing and internet saturation