Reverse stop click

We have a folder on a server that had a lot of data. We right clicked on this and synced to a folder on odrive. The folder on the server has been right clicked and the ‘stop’ command was clicked by accident, rather than ‘remove from sync.’ This seems to be deleting the local data.

We have clicked ‘remove from sync’ and the sync seems to be removed. How can we stop the ‘stop’ process and the deleting of the local data?

Hi @itadmin2,
This definitely should not be happening! I am looking into how this would be possible, but for now I would recommend renaming the folder that is being affected to stop odrive from “seeing” it. Removing sync should have already done that, but this should guarantee that odrive can no longer find the folder.

Can you send a diagnostic from the odrive tray menu, as well, so I can take a closer look at your configuration and the recent events?

Hi @itadmin2,
I’ve been testing and going through the code, but I cannot find a scenario where this is possible, yet.

A right-click->“stop” command will halt the current running uploads, but they will be queued to resume and start-up again after a short period of time.

The right-click->“remove sync” command will remove the path completely from odrive’s knowledge. This action, alone, should stop odrive from performing any more actions on the folder in question because it will no longer know it exists. I cannot see any way for odrive to continue to act on the data after this has been done, so I’m wondering if it is possible that there could be something else acting on the data in this scenario.

When you get a chance, can you provide me with as much detail as you can on the details of your scenario and the actions that were taken leading up to this point?

Some specific questions I have:

  • Which operating system version is the server running?
  • What remote storage are you using for this folder?
  • How long had the sync operation been running prior to clicking the “stop” context menu option?
  • Were the items that were being deleted being put into the OS trash or just disappearing completely?
  • Are there any other processes, systems, or users that are also monitoring or acting on this folder or the data in this folder?
  • Were the items that were disappearing files that had not yet been uploaded to the remote storage?

This is something I want to get to the bottom of immediately, so I will be continuing to comb through the code and test. When you get a chance, please take a look at the information and questions above.

Hi @itadmin2,
QA and I spent the day digging on this, but we weren’t able to reproduce this issue or identify a place in the code where this would happen.

When you get a chance, can you review my posts above and see if you can help to fill in some of the blanks?

Hi Tony,
Thanks so much for looking into this in so much detail so quickly and apologies for the slow reply.

This environment is a co-managed support environment, so we are working with the existing on-site IT support. For this reason, we do not have full access to the server, otherwise I would grab all of this information for you now but here is some further information:

  1. Server 2016 on a Citrix VM.
  2. Google Team Drive.
  3. I will find out.
  4. We had a dialog box appearing for some items that said ‘the folder contains items whose names are too long for the Recycle Bin.’ For the other items, I am not sure as I have not been able to investigate on the server
  5. It is a shared network folder, so yes there are other users acting on it. I do not believe there are other processes acting on it, other than perhaps anti-virus.
  6. I will attempt to find out.

Sorry to sound vague but as mentioned, due to this being a recent co-managed client of ours, we are still setting up access.

I will get the diagnostic logs for you too.

Thanks for the follow-up @itadmin2.

I’m relieved to know that you were seeing the messages for the Recycle Bin, which means the items were being put into there and can be recovered instead of just disappearing entirely.

Is it possible that anyone could be modifying data on Google Drive, directly, or is all user interaction done through the network share?

The diagnostics may be able to tell us something if they can capture this behavior. What is the current status of the system?

Hi Tony,
I have sent the diagnostics via the odrive system tray now. According to the onsite IT and users, there were some certainly some folders deleted, around 8GB we believe. The files and folders have been restored from a backup and the system appears stable now.

An example of missing folders is within:
Mathematics/1. NEW Mathematics/ABT

When looking at the ‘Trash Bin’ on the odrive menu it says ‘Mathematics’ as a folder (which is the folder in question). The setting in odrive is set for empty trash immediately.

Nobody was interacting on Google’s end as the shared drive had not been shared out to anybody, we were waiting for the upload to finish before sharing.

Hi @itadmin2,
I took a look at the diagnostics. Unfortunately it starts this morning, so I won’t be able to gain any insight into what happened last week.

The Mathematics folder in the odrive trash is a “Shared Drive” (Team Drive) folder. It is still there because odrive can’t delete these folders remotely (when it tries to it gets an error). You can restore that folder from the odrive trash.

Was anyone able to take a look at the server’s local recycle bin to see if there were items put into there? I am curious as to what will be found there.

During our exploration of this issue, we did find one potential scenario where unsynced items could be moved to the local OS recycle bin. This could be triggered if a local folder had synced to the remote storage, but that local folder’s contents had not yet been uploaded. If the corresponding remote folder was deleted, odrive would put the local folder, and the contents of that folder, into the OS Recycle Bin. We have made an adjustment here to recreate the folder and continue uploading if this scenario occurs. From the infomormation so far, it doesn’t sounds like this occurred in your case, but it may be possible that odrive somehow interpreted something it saw as a remote folder delete, which triggered this behavior.

Aside from the find above, we haven’t discovered a scenario that can result in deleting data locally, but we are continuing to look. If you are able to discover anything else on your side, please let me know.

Thanks for your help in investigating this. I appreciate it!

Hi Tony,
Ah that’s very interesting and is actually what may have happened. The folder was definitely part way through uploading when the action was taken. It is possible that the person carrying out the action did something along these lines.

I believe they have emptied the recycle bin, so probably not anything of use in there to see.

Apologies for not being more insightful but due to the limited access to the server and knowledge of the exact sequences of events, it makes it a bit tricky.

At this point in time, it seems to be stable. We are going to start again and attempt the upload again. Thanks very much for your assistance.

Thanks @itadmin2. Just let us know if you hit anything else. I expect we should have the new release with the above change within the next week or so.

Hi Tony,
Unfortunately we are still having some issues. I have sent a diagnostic log.

This has now become a bit of a mess and we are not sure what to do from here. We are now in a situation where the original mathematics folder on Google that we syned to was renamed to mathematicsold. This cannot be deleted even though it is empty.

We have tried syncing the local mathematics folder to a new mathematics folder on Google Drive but that just reported it was invalid. Now when we right click the mathematics folder, the only option we have it ‘sync to odrive’ if we click that is reports that it is already an odrive folder.

Hi @itadmin2,
I just took a quick look.

If you go to the odrive tray menu under “sync to odrive” and click on the Mathematics folder there, does it give you the option to “Remove sync” on it? If so, do that and then you should be able to “sync to odrive” on the Mathematics folder and point it to the correct one.

Hi @itadmin2,
If you are still seeing issues, try a quick restart of odrive, too. I saw an error about the local database being busy and a quick restart should address that if it doesn’t resolve quickly on its own.

Hey Tony,
We seem to have it sorted now. Thanks for your reply, I will post again in a moment to let you know the resolution steps.

Hi @itadmin2,
Thanks for the update! I’m glad you were able to get things sorted out.

I would definitely like to learn what the resolution was to see if there is anything we can improve. If you are able to find an opportunity to post that I would very much appreciate it.

Hey Tony,
So we did a combination of things but it is clear that odrive had linked the local Mathematics folder to the Google Shared Drive folder, even after the Shared Drive folder was renamed.

We renamed the Shared Drive folder to Mathematicsold. We created a new Shared Drive folder called Mathematics. After that we tried syncing again and although odrive allowed us to select it, it clearly wasn’t right. After thinking for a while, the folder showed as invalid on the odrive menu (under sync odrive folder).

When we right clicked on the local Mathematics folder, we had no option to remove the sync, the only option was ‘sync to odrive’. We then tried deleting both of the Shared Drive mathematics folder but this did not work as they seemed to think there was data inside (even though they were empty when going into them).

Eventually after trying to delete the folder in the local odrive folder and encountering problems, we went to sync odrive folder and clicked on the invalid mathematics entry. Odrive asked us to remove the folder which we clicked to do and this seemed to break the link.

We still could not delete the shared drive folders and I wanted to make sure we did before attempting the sync again. The next morning we tried deleting the shared drive folders again and they deleted this time.

We were now in a position to start again, there were no mathematics folders on Shared Drive and odrive had no record of them either. We then created a new Mathematics folder on Shared Drive and synced from odrive in the normal way.

Everything is fine now but yes, it was a weird situation and a lot of trying different combinations of deleting to get it to work.

My thinking is that Google Drive works in a way whereby when you tell it to delete a lot of data, it shows you the data is gone but actually it is still there. It must place the job in a queue somewhere, for processing later. Possibly to help load-balance the data centre - who knows!

Hope that helps.

Hi @itadmin2,
It definitely helps! I appreciate the details.

I have seen that same behavior with Google, where large-scale delete operations can take a long time to actually process. I’m sure that was contributing to the issues you were seeing.

I also wanted to let you know that we’ve released a new version of the clients and this one has some extra safeguards in place based on your feedback.

We haven’t released it to the auto-updater yet, but you can grab it from our download page.

Thanks Tony, really appreciate it.

1 Like