Repair Invalid odrive-agent-mount

Not sure what happened, but for some reason when I check on the status of the my odrive-agent-mounts I am seeing the status as Invalid. Is there any way to repair this? Or do I just need to delete the mount and start all over again. . .

Here is the terminal output:

pi@raspberrypi: “$HOME/.odrive-agent/bin/odrive” status --mounts
/home/pi/odrive-agent-mount status:Missing
/media/pi/HD1/odrive-agent-mount status:Invalid

Any ideas or help would be most appreciated.



Hi @brian.michaud1,
“Missing” indicates that odrive can’t find the specified path.
“Invalid” I’m not so sure about, it could amount to the same root problem.

Did the permissions changed on those folders? Are they accessible (rwx) by whatever user the odrive agent processes is running under?
Does restarting the agent process change anything?

Well, that was uneventful. I restarted the process and it came right back. Very strange. . . I tried that before and it worked, but it didn’t seem to this time. Glad it’s resolved! Thanks for the help Tony!

Great! Thanks for the update.