Onedrive for business just stopped working after no changes

I can’t use my onedrive for business all of a sudden. It was working fine, but now says authorization has failed and it will not let me do anything. I’ve checked my settings on Office 365 and it says Odrive has permission to access. What do I do? Please help. (other cloud services work)

1 Like

I’ve got this problem too

Same problem here!!!

Any news? Is there way to know when the problem will be solved?

We are investigating and will provide an update when we know more.

also having this issue. tried deleting and re-adding, but no luck.

Yep, me too. Same problem. :frowning:

@mikematousek @si1 @e.david @justinfowler @eric.n.ferguson
This should be fixed now. No need to unlink and relink. Can you please verify?

1 Like

Onedrive has stopped synching today, and odrive keeps throwing up the ‘re-authorize’ message. Trying to reauthorise just fails, and I just get the paid that says ‘try again’. I’ve checked permissions on onedrive itself, and odrive has been authorised. (I removed and re-added, but it hasn’t solved it).

If I remove it completely and re-add, will this have to download all my files again? would rather not re-download several GB if I can avoid it…

Was working perfectly up until about 12pm today.

Thanks for any help or comments,
Mac OSX 10.13.1
oDrive: prod 6344

Hi @garrett.kennedy,
Please see above. This should be fixed now.

1 Like

At first I still got the authorization issue but now I managed to resync

1 Like

Woo! Awesome! Thanks guys! All working again. :slight_smile:

1 Like

When I had the problem I tried unsyncing and syncing Onedrive and of course this would have deleted all my files: for this reason, I stopped the odrive client before and moved everything somewhere else.
Now I simply restarted the client, opened the root Onedrive folder with the placeholders, stopped the client again, copied all the files back and odrive accepted the “new” files and replaced the placeholders.
Just posting this because it may be of help for somebody else, to avoid resyncing everything.
Thanks @Tony for the very fast response on this!

1 Like

It works for me ! :grinning:

1 Like

Thanks for confirming everyone! Apologies for the inconvenience.

Confirmed fixed, thank you!

1 Like