Odrive won't sync

My odrive has stopped syncing. I’m running version prod5689 on Windows 10. The icon is white instead of pink, even though there are files ready to upload. This is to several cloud services - Amazon, onedrive etc.

Trying to download a file I get the error message

Unable to sync filename.cloud.
Please check your network connection or manage your proxy settings.

My internet is working fine (I’m using the same PC to send this), and I am able to download the files using odrive web service.


  • Can you send a diagnostic from the odrive tray menu and then ping this thread?
  • Can you also try restarting odrive, please?
  • Have you switched networks or anything on the network between the time it was working and the time it wasn’t?
  • Do you have any network proxys in play?
  • Do you have any anti-virus or endpoint protection software running?


Ive just sent a diagnostic. I’ve tried restarting odrive several times as well as several reboots. I was on the same network since it was working yesterday. I normally go through overplay smartdns but I’ve tried without that and it is the same. I’m running McAfee Livesafe, but have been since before I had odrive.

Oh dear! I thought I would try a reinstall, so I uninstalled odrive and downloaded and installed the latest version - now 5720. I click on Set up odrive and it takes me through few screens I get an error
Unable to connect. Please check your network connection. Then I get the windows login screen and it logs me in. I get to the “Open Odrive folder” screen but it doesn’t open - it then says “Thank You” and that’s it. The tray menu still shows “Set up odrive”

I’ve turned off McAfee while I’m doing all this.

An Update. It seems my PC was part way through downloading the Anniversary update. I let it continue and completed the update. When it was complete Odrive was still not setting up. I noticed that the manual prox was switched on and there were some strange settings in there which I can’t remember adding - Certainly not in the few days since Odrive was last working.

I disabled it and voila! Odrive then installed and is working again! I’mm not sure why it worked with the proxy set until a few days ago, but then stopped working. Maybe one of the updates?

Thanks for much for the continued updates. It sounds like maybe some settings were tweaked/changed during the Windows update that may caused things to go off the rails a bit.

I’m glad you pushed through to the other side. :slight_smile:

Hi, could you explain more about these settings? I’m having a similar issue and don’t really understand the proxy settings. Where do you disable as you say?


The gist of the problem when you see “Please check your network connection or manage your proxy settings” is that sync cannot be completed because the app is having trouble reaching the storage source over the internet.

The conversation above had some discussion of manual proxy server settings–you can find these settings on Windows by doing the following:

  • Press the Windows button on your keyboard
  • Type in “Settings” to search for and start up the Settings app on Windows.
  • When the Settings app comes up, click on the “Find a setting” search box at the top and enter “proxy” which will allow you to select the “Network proxy settings” option.

This is where you’ll see the “Manual proxy setup” section that the previous poster was talking about. You can turn off the switch under “Use a proxy server” under the “Manual proxy setup” section.

However, your problem may or may not have anything to do with proxy server configurations. I wanted to again emphasize that that message just means there’s an internet connection problem.


  1. Do you use a proxy server to connect to the internet (either at home or at work)?
  2. Have you ever had odrive working before and then it stopped?
  3. If “yes” on #2, then have you switched networks or anything on the network between the time it was working and the time it wasn’t?
  4. Can you also try restarting odrive?
  5. Do you have anti-virus or endpoint protection software running?
  6. Can you click on the odrive tray menu icon and select “Send diagnostic” and let us know when you’ve done so?



In answer to your questions:

  1. I don’t think so!
  2. No
  3. I restarted but nothing has changed.
  4. I have McAfee Antivirus
  5. I have sent the diagnostic.

Thanks for doing the above… There does indeed seem to be a network issue, but it’s with SSL certificate validation failing. (When we connect to Google Drive on your behalf, we always use an encrypted channel… a SSL certificate is a sort of identification card so we know that we’re talking to the real Google Drive and not someone claiming to be Google).

I’m not sure why it would be failing… I’ll need to consult with some others on our team.

In the meantime…

  1. Do you ever bring your computer with you to different places with different networks? I’m wondering if you only see this problem when you’re connected to a particular network (e.g. work, or home).
  2. Also, on a longshot (not likely to work), can you try disabling McAfee Antivirus and then seeing if you still run into the issue? If you still do, then you can turn McAfee back on.
  3. Also on another longshot, can you check your computer’s date and time settings and make sure it’s not somehow way off?


Hi Jeff,

THanks for your help. I don’t move to different networks often, mostly just use my home network & can’t remember the last time it was connected elsewhere.

I tried disabling Mcafee but no change and the date & time are correct.

Thanks, Jennie. Can you please try something else for us to get us more information on why your certificate verification is failing? The URL in the screenshot (so you can just copy-and-paste) is here: https://www.googleapis.com/drive/v2/about


P.S. Keep clicking on the image below to get expanded views… the forum seems to have compressed it down into a thumbnail, so click on it a couple of times until it appears big enough to look at / read legibly (and so you can fully see steps 3, 4 , and 5)

I have found that we are using Covenant Eyes as a proxy (I never knew what proxy was before!) - and I’ve contacted them & updated as they recommended but still odrive doesn’t seem to be working.

Here is what I see:

I’m not sure if you’ll see this now, but I’ve been using odrive on this computer as is (with this proxy I guess?) since downloading odrive months ago. I also have another computer which uses the same thing & is working perfectly with odrive. So I don’t really understand your response?

Hi Jennie,

We don’t currently support connecting through a proxy server yet. Some people find that some requests work (e.g. if not uploading or downloading anything, you can see your files, etc.), depending on their proxy environments and such, but that may lead to some false hope since it won’t work as expected.

There’s an outstanding feature request for it here in this other thread:

Sorry we can’t help in your current situation. If you stop using a proxy to connect from home, that could help, but I realize that you may need to connect via proxy for other reasons. It’s also possible we may be able to support it in a future release, but there’s no estimate for when that may become available.