Odrive won't start on mac with older hardware

This is strange. Can you open up a terminal session and copy and paste this command in?
bindir=$(ls -d "$HOME/.odrive/bin/"*/ | tail -1); echo $bindir;"${bindir}odriveapp.app/Contents/MacOS/odrive"

Hi, I get…

ls: /Users/username/.odrive/bin/*/: No such file or directory

-bash: odriveapp.app/Contents/MacOS/odrive: No such file or directory

Hmm. This was an upgrade? If so you should have the bin folder.
Can you run this?
find "$HOME/.odrive" -type d -maxdepth 5

and then run this?
"/Applications/odrive.app/Contents/MacOS/odrive" -v


find: /Users/username/.odrive: No such file or directory

Illegal instruction: 4

Well I upgraded to start with but when that didn’t work I tried uninstalling, downloading and reinstalling again before posting here

Okay, one more command to run:
sysctl -n machdep.cpu.brand_string; sysctl -n hw.model; uname -a;

Can you also see if there are any crash logs available to send me. You can pm them to me, if you like. You should be able to find it under “User Diagnostic Reports” in the OS X Console.


Intel® Core™2 Duo CPU T7500 @ 2.20GHz
Darwin myMBP.home 14.5.0 Darwin Kernel Version 14.5.0: Mon Aug 29 21:14:16 PDT 2016; root:xnu-2782.50.6~1/RELEASE_X86_64 x86_64

Crash report messaged to you


I think I know what the issue is. The core 2 duo you are running is one of the original versions. I believe our build has some optimizations that are incompatible with your processor. We tested against core 2 duo, but a later model from 2008 (vs 2006 for yours).

We need to look into this a bit more on the build system to see what can be done, but it will take some time.

Apologies for the inconvenience @r3241

ok thanks for letting me know, looking forward to it

Same issue here with new update though I’d been working well for a while once the previous issue on Core2’s were fixed.

I displayed similar results to r3241 except for the “find “$HOME/.odrive” -type d -maxdepth 5” command which returned folders/locations.

sysctl -n machdep.cpu.brand_string; sysctl -n hw.model; uname -a;

Intel® Core™2 Duo CPU T7700 @ 2.40GHz
Darwin MEGALODON.local 15.6.0 Darwin Kernel Version 15.6.0: Mon Aug 29 20:21:34 PDT 2016; root:xnu-3248.60.11~1/RELEASE_X86_64 x86_64

@r3241 - I was able to successfully (re)install a previous build (5719) over the most recent build which repaired my icon and right-click menu actions. I had tried the build 5759, but that did not repair the menu bar icon or folder menu actions. I immediately received an update notice, but will be reminded tomorrow to update… :slight_smile:

Here’s the download link I used to get the 5719 build: https://d3huse1s6vwzq6.cloudfront.net/odrivesync.5719.dmg

Good luck!

(And looking forward to a fix @Tony…)


I am running osx10.9.5 on an xserve with dual xeon CPUs, 2006 but upgraded cpus and hacked to load Mavericks. Not surprisingly the latest version of odrive will not run, though it did before without any issue. Is there a version I can install that might work?


Hi Chris,
I added you to a conversation where we have a new version you can try. I believe this is fixed in this version, but would love your feedback. We would like to release this publicly if things check out.

Thanks! I installed it but it does not run.


odrive_2016-09-26-170945_Idris.crash (50.7 KB)

Hi @cbelcher,
I responded in the private group message, but will post here too.

Make sure you are installing the proper version. There are several versions posted in there that don’t work (were experiments while trying to solve the issue. The correct one is listed at the very bottom.

Hey, running into the same thing on my Mac Pro 1,1 running Yosemite.

My results for the brand-string command:

ntel® Xeon® CPU 5160 @ 3.00GHz
Darwin redacted-Mac-Pro.local 14.0.0 Darwin Kernel Version 14.0.0: Fri Sep 19 00:26:44 PDT 2014; root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64

Crash log:
odrive_2016-09-26-185347_Morgans-Mac-Pro.crash (35.4 KB)

Hoping to get in on the new fancy shiny version that will hopefully work on my machine. :slight_smile:

Hi @odrive2016,
I added you to the conversation.

A fix has been released for this:

Thank you , Tony!

Version 5998 seems to be working, but as to be expected it did flash a big warning that it is not compatible with my software (10.9.5). Thank you for the scripts! The folder I action I use most is “copy shared link to clipboard”. Any chance of getting that working in Mavericks? Luckily I do have it installed on Windows, but it would be more convenient to be able to work with archived files from the server.

Incidentally, while trying to find a workaround to share a file with a client who needed it right away, I tried to use the web interface. Using Firefox, Chrome and Safari, I was completely unable to share the link. The folder was at the bottom of the page, and there seems to be no way to reorder the listing. When I clicked the arrow to the right of the folder, the dialog opened inside the window but below the bottom edge, where it was completely invisible, and there was not a way to scroll down to reveal it. I spent a good thirty minutes trying to make it work before giving up and moving to the Windows laptop. Very frustrating.

Hi @cbelcher,
Glad to hear the client is working again for you!

There isn’t currently a way to facilitate the shared link action, but I will request that it be added to the CLI so that this becomes an option.

The web is a viable alternative without switching to your other machine. The behavior you saw is definitely a little funky and we should address that. The next time you run into it, try hitting the down arrow on your keyboard after clicking on the “v”. That should allow you to select “Share”. Mouse scrolling should work too, but it sounds like it wasn’t on your machine.