ODrive Sync (5116) not starting on Windows 7

Hi,
I installed the ODrive Sync client (v5116), but I don’t see the window nor the process running in Task Manager.
After clicking odrive, the wait icon appears for a few seconds and then disappears.

OS: Windows 7 SP1 64-bit

I have tried the following so far, without success:

  1. Running odrive.exe as administrator.
  2. Running odrive.exe from command-line.
  3. Uninstalled & Installed again.
  4. Disabled anti-virus, started odrive.

Attached is the log file generated from this command: odrive.exe -v > %userprofile%\Desktop\odrive_out.log

Note: The forum didn’t allow me to upload a file, so pasting the content here:
–Log Begin–
Starting launcher with verbose output…
No product argument was passed in. Attempting to find product.conf…
Using path c:\PROGRA~1\odrive\product.conf…
Using C:\Users\beyondsquare.odrive as the installed folder path…
Attempting to mark the installed folder path as hidden…
Writing the product.conf file at C:\Users\beyondsquare.odrive…
Reading the version number from the version file…
Attempting to read systemAlertRoom from config…
Setting up diagnostics for buildNo: 5116, productName: prod, systemAlertRoom: 1358891
Creating launcher object…
Checking if another odrive process is running again to reduce the chances of a race condition…
Launching…
Got WindowsError exception [Error 2] The system cannot find the file specified
Traceback (most recent call last):
File “”, line 178, in main
File “C:\hudson\workspace\Odrive_Win_Master_Launcher\deploy\output\artifacts\build\odrive\WinOdrive\out00-PYZ.pyz\src.odrive_app.Launcher”, line 162, in launch
File “C:\hudson\workspace\Odrive_Win_Master_Launcher\deploy\output\artifacts\build\odrive\WinOdrive\out00-PYZ.pyz\src.odrive_app.Launcher”, line 116, in _launch_app
File “C:\hudson\workspace\Odrive_Win_Master_Launcher\deploy\output\artifacts\build\odrive\WinOdrive\out00-PYZ.pyz\subprocess”, line 710, in init
File “C:\hudson\workspace\Odrive_Win_Master_Launcher\deploy\output\artifacts\build\odrive\WinOdrive\out00-PYZ.pyz\subprocess”, line 958, in _execute_child
WindowsError: [Error 2] The system cannot find the file specified
Could not launch, which means the app is already running
–Log End–

Thanks!

Hi,
It appears to be failing when trying to launch odriveapp.exe. Can you try running this manually? You should find it at: C:\Users\beyondsquare,odrive\bin\5116\odriveapp.exe

.odrive is a hidden folder, so you will need to have the option to show hidden files and folders enabled in Windows Explorer

Thanks!

Hi Tony,

I did not find the “odriveapp.exe” file in the hidden folder “C:\Users\beyondsquare,odrive\bin\5116”…which was strange.
So I uninstalled odrive, and then deleted the “.odrive” hidden folder.
After re-installing odrive, it worked fine now.

Just FYI, there was a previous version folder 5110 in the “.odrive” hidden folder. But I couldn’t delete it as some of the dll files inside were showing locked by explorer.exe. (I had to go through some hoops to delete the folder).
This may have been causing issue with the new version installation.

Thanks for your support!

1 Like

I had a related issue: On Windows 10 I restored my computer using system restore - now odrive was gone so I had to reinstall but it didn’t start.

Solution: Uninstall odrive, delete the .odrive folder you mentioned earlier and then reinstall odrive.

Thor

1 Like