Odrive stopped working after latest Windows 10 update

since the Windows 10 update from last night, my odrive won’t start anymore.
Whenever I click on C:\Program Files\odrive\odrive.exe I receive an “Windows cannot access the specified device, path or file. You may not have the approprieate permissions to access the item” error message.

I already tried reverting to an earlier restoration point, tried reinstalling the program, checked the permissions inside the folder, tried running the program in compatibility mode, tried to exclude program from windows defender and I’m officially out of ideas…

Can anyone help me?

Hi @dclp.wagner,
Can you take a look at this article and see if anything here resolves the issue. Specifically methods 1, 5, and 6


Thanks for your quick reply Tony!
I have recheck all the steps on the link you just sent me, and I still receive the same error message when opening the file.
The awkward thing is, yesterday everything was working perfectly…
All other programs I checked are working perfectly.

I don’t suppose you have another idea, do you?

I just tried installing another anti virus program… same error…

When you reinstalled odrive, did you do an uninstall and then a reinstall? If so, was the odrive.exe file removed on uninstall?

What anti-virus apps are you running currently? If you haven’t already done so, can you make sure any running are disabled?

What happens if you rename odrive.exe to notepad.exe?

Are you able to run the main odrive app from [You user directory].odrive\bin[version#]\odriveapp.exe?

The first time I just did a repair installation. Then I completely uninstalled the program, restarted my computer then installed it again. In the mean time, those updates I suspected were the cause of my problem got reinstalled by Windows (as I tried to fix my problem I did a roll back to a date before those updates).
I was using Windows Defender and installed Avira Connect, since I read in some forums that the permission problem could be caused by an anti-virus program. That also didn’t work.
I also tried your suggestion renaming the odrive.exe to notepad.exe… the same error message appeared.
As for opening the app from [You user directory].odrive\bin[version#]\odriveapp.exe, the folder wasn’t even created during the install process…

Yesterday night I turned off my computer an went to sleep… today as I turned it on “magically” the odrive setup message appeared and everything is working like 2 days ago!
I have absolutely no clue why but I’m happy it’s working! I’m still suspecting it had something to do with a Windows update.

Thanks for all your suggestions.

How strange. I am glad to hear it is working again!

I agree that it seems linked to the update. I wonder what was going on there…

Thanks for the update!

I have the exact same problem. I have just updated Windows 10 and Odrive is not working anymore. And I get the same error when I try to launch odrive.exe

Hi @rjansenbr,
Did you check out this article to make sure one of the methods listed would fix the issue?

It didn´t work :frowning:

Hi @rjansenbr,
We can try an uninstall and reinstall of the software. This will backup your current odrive folder and then start things fresh, but hopefully it will get around whatever is causing this issue. Are you willing to give that a shot?