Odrive is dead on latest Windows Insider build (16193)

I am Windows Insider. A few days back, I got insider build 16193, and from that build, Odrive is dead. No processes active, no tray icon, simply, nothing. Uninstalled, deleted remaining data, installed again, and situation is the same. ODrive cannot be started. No Errors, no messages. Simply, nothing.

Same here. Build 16193 and odrive will not even start anymore. I tried manually starting the .exe and it just closes with nothing logged. Even tried odrive.exe -v and nothing. dead on latest build of Win 10

Same here.

I got a pop-up for a missing DLL file the first time actually.

I’m also posting this in the Windows Insider Hub as well.

Me as well.


Hi folks,
We will need to look into this further with our QA team.

Some cursory searching/reading indicates that this may be a more wide-spread issue than just odrive, as per this thread here:

We haven’t changed anything recently in our build, so it sounds like something may have broken in this insider build.

In the thread above several people indicate that this could also be related to 3rd party virus scan software. Is anyone using Avast, AVG, Norton, etc software?

Hello, recently I just notice that my amazon not syn like normally on my pc
and turn out odrive icon in toolbar is no longer there, I do check the process and it still there

I try restart many times, I try repair , I try reinstall the software, I try uninstall and installing back
nothing work

Windows 10 Pro insider preview
build 16193 prelease.170507-1300

please help

Please see above

Not using any antivirus other than the default Windows Defender.

We’ve been able to reproduce this, but it is a very odd problem. No errors, no crashes, no events, no exceptions… nothing. When you launch odriveapp basically nothing happens.

We are still looking into it, but since this is a pre-release of Windows, it seems like something MS broke in this version.

Quick update:
We found that if you right-click on C:\Users\[Your User Name Here]\.odrive\bin\[version]\odriveapp.exe and set it for “Windows 8” compatibility in the compatibility tab, odrive will run on 16193.

Still trying to figure out why this would be needed since we have not had issues with Windows 10 prior to this.