Odrive error: "Cannot browse pw-SFTP. SFTP server error."?

This seems to be different than the issue in the link below, as it worked for months, and now fails.


Tried connecting via sftp with winscp client, and worked fine with existing credentials.

Changed odrive setting to have it go to a directory rather than root, but no luck.

Any ideas?


Hi Mark,
Does this generate an error on the odrive web client too, or just on the desktop client?

If possible, can you create test credentials that I can use to see if I experience the same thing (can send via PM).


Hi Tony,

Two things:

It was failing on the client side. Found that the files I wanted it to sync were marked ‘read only’ in windows for some reason. When I removed that restriction, the client worked fine. I’m not sure that’s how you want it to work, though.

However, odrive site access continued to fail after changing file. I’ll send login credentials tonight.

Hi Mark,
Are you able to send those test credentials?

Duh, whoops - totally spaced it. Here you go:


virtual hosting by 1and1.com, if that helps.

Thanks. I will check this out today. I know that 1 and 1 have some odd restrictions on number of connections that could be causing an issue.

It was working for a month or so, then stopped, but I guess that doesn’t mean 1and1 couldn’t have changed something on their side. Thanks for keeping after this.

1and1 definitely has some … interesting… restrictions on connections. Can you try changing the “CONCURRENT CONNECTIONS” setting on that link (using Edit on the link from its listing in the web browser), and set that to 1? That might help.

Hey Mark, I use 1and1 for my personal web hosting, too. I was complaining recently about similar disruptions in my ability to access my files but it seems like its better now - not sure if they cleared up somethings or what.

Could you try it again? I limited the connections made to 1 and that seemed to help. Let me know what you find.

  • Aric

I went from 3 to 2, and it’s behaving much better. That said, I’ve had an unsettling event occur that’s letting me test this extensively…

My photo collection is backed on this sftp connection. All the photos were synced locally. 2 days ago, i went to open a file with my photo software, and it wasn’t there. When I looked, all my hundreds of files had become odrive place-holders. I’d like to think that I didn’t somehow accidentally un-sync the whole sftp drive. But if I did, it would have been nice to get a confirmation dialog box. E.g., “You’re about to delete all the files in [folder} from you computer, but they still be on your [cloud storage], and available via odrive placeholders.”

Or maybe a ‘never un-sync/sync lock’ option?

Hmm…odd that you’re files would turn to placeholders without you taking action.

First question - is all your stuff still in your remote location? (like you didnt lose anything permanently)

Second - Did you by chance uninstall and reinstall? That could recreate your odrive folder - which would keep all the photos you previously had synced in a dormant odrive folder that could be found under your userprofile/Users - names something like odrivebackup-date. The new odrive folder would be a fresh folder - requiring you to retroactively sync stuff.

Third question - Doesn’t sound like this, but could Auto-Unsync have been set? (Can check this from the tray menu - “Never” would be the setting you want)

You’re right we don’t currently make you aware of your unsyncing, whether you right-click and do it yourself or whether its part of an auto-unsync policy you’ve set. Will relay the feedback, but as you can imagine their are those out there that found a prompting window for unsync annoying (which is why its not there). But totally hear your concern - when it comes to important stuff, its better to be sure you’re performing the action you want.

I’d like to verify though that things aren’t just getting unsynced all willy-nilly.

Hi Aric

I’m sorry to say that resyncing has has blasted this to a whole new level of fubar, and I/m done with it. No idea how this is possible, but not only do I have the original files back in the original file structure, but I have a copy of every file that ever was anywhere in the file structure since I started using odrive. I had about 4gb’s of pix, but now I have 11. And, of course, the photo software database is thoroughly out of sync. I’m not even sure where to start cleaning this up.

In answer to your questions:
Nothing was lost
Did not uninstall/reinstall
Auto-unsync is a premium feature which I don’t have
Unsysc prompt - Add it by default with a “never show this again” check box.

Sorry this blew up - Love the basic utility of it, but I won’t risk going through the clean up I’m facing again. Maybe I’ll be back in a year.

Thanks for trying to make this work.

Sorry you hit some trouble here. What you describe is really strange. Almost as if a circular symlink reference was hit, or something to that effect.

If there is a pattern to the duplication we could probably come up with something easy to cleanup.

Dunno - I never looked at the server my files were syncing to, except after the first big sync to see if they were there.
I can tell you that deletes didn’t delete, moves were executed as copies, and renames resulted in two files. I don’t have any problems with winscp sftp transfers. The server space is just 1and1 virtual hosting, so I don’t have enough access to do any serious investigating.

Fortunately, I’ve done a LOT of file and DB cleaning over the last 35 years, and it’s relatively painless to get rid of all the oldest versions with dupe finder software, Unfortunately, the DB no longer has any idea what it was pointing to - that’s going to have to be redone from scratch. Thanks for the offer, though.

Thanks for the feedback.

My own SFTP use does not exhibit these behaviors, but it could be differences in the servers. Delete’s not reflecting was likely due to the odrive trash not being emptied. odrive keeps all deletes in a “trash” to prevent inadvertent remote deletes. This is especially important for sources like SFTP, which don’t have any native trashing or versioning on the storage itself.

It is possible that some moves and renamed were being picked up as adds and deletes rather than moves, which would appear as duplicates without emptying the trash.

In any case, just let me know if you start using odrive again and we can take a look at some of these specific issues in more depth.