ODrive does not sync with Amazon S3

I have connected my S3 accounts several times with Odrive and it has never worked. I just connected a new user I made just for odrive that has administrator access on S3. Odrive says that everything is working, but the files are not showing up in Odrive and the files I upload to odrive are not showing up in my bucket.
There are no errors and everything seems to be correct accept there is no sinking between the two.
Any idea what is going on?

Hi @brandonkeithbiggs,
Is anything showing up on S3?

A common point of confusion is the S3 link setting. There are two ways to link a bucket. Take a look at this post for some information on that:

If you are connecting to a bucket with existing data in it, then you will most likely want “Simple ‘/’ Delimited” vs “Enhanced odrive FS”.

perfect! that solved the problem and now I can see everything! So just for others who read this, the option to change the folder structure is in Odrive under the edit item. It is the last thing before the save button.

1 Like