oDrive crashes when "Sync All"

I have a user in our organization who is using oDrive, but when they “Sync All”, the application crashes.

Problem only occurs for this user, and we have tried restarting. Not sure what is going on.

Mac OS X latest version

Hi @wh33ln,
This is when the user right-clicks on a folder and selects “sync” and then choses “Everything” and “include subfolders”?

Does this happen every time?
What if you do not include subfolders, or set the slider to “Nothing”, or a combination in there?

If you can grab a couple of crash reports - you can look for one from the console (type console into Spotlight search) in the “User Diagnostic Reports” section - I can see if anything stands out.

We have tried just about every variation in testing including those you mention above. I will send these crash reports to you now.

Thanks @wh33ln,
The crash happens as soon as the large silver sync button is clicked on the sync window?

@wh33ln Can you also send a diagnostic from the odrive menu?

Also, you mentioned the user was running latest MacOS, but they are actually running El Capitan (10.11) vs Sierra (10.12)

Just now sent the diagnostics.

He is on 10.11.6 El Capitan. I can go ahead and get that update if you think that will help

Ok… Updating the OS resolved the issue…

Thanks for the update @wh33ln. I was going to say upgrading can’t hurt, but I wasn’t sure if it would resolve it. Glad it did.

Ok. Issue returned same as before. I just now sent an oDrive Diagnostic report, and will send over a crash report as well.

Hi @wh33ln,
The thread this is crashing in is doing something pretty basic, so its hard to tell why its happening here. Is this the only application crashing on this system? Is there anything else of interest about this system?

By the way, the crash report shows that this system is still running 10.11.6, which is odd. Did the user revert back?

I checked in with the user, and we are not sure what happened because it looked like it completed the update, and he said the issue was not there anymore. Needless to say, We have updated OS X and will see how it reacts now.

1 Like