Not Allowed (200+) with Amazon Drive

When I left-click Odrive in the system tray, it is reporting 200+ files “Not Allowed”, and when I right-click one, it says “Illegal file name.” The file names look like encrypted files (e.g., “MUjSfQBdRjrjs6eM4Wa5Jt4…”). I’m using Amazon Drive, and Windows 8.1. And I just clicked “send diagnostic.” Please help.
[Edit: P.S. And now I just noticed the following error message: “There was an error sending the diagnostic report: out of memory”]

Hi @mbarre2004,
Was a “current_odrive_status.txt” file created? It will be in the root of your odrive folder. I can take a look at that if you attach it here.

Also, can you try a restart of odrive and then send a diagnostic after items start apearing in “Not allowed”?

Thanks for the prompt response. I rebooted and tried the Send Diagnostics again, but it failed again. But it apparently did create a current_odrive_status.txt. it is 10,264 KB in size. Below are the first few lines, but I’m concerned about confidentiality. If you need more of it, is there a more secure way for me to get it to you?

odrive Status

Trash (0):

Not allowed (5808):
MY8NgEo4TOsl_PR41DtX3BkaBPeUXPC8HhZeIsjjSRJvEU5UxkciQu_klxA4ERlxntM9z8Q1O4s-idBbUhvnLHkcVqE_MlEe4CyBcveLkiLRkMUwT7mKBG9Ad5yfO1n1dZq1EJaKbKz4nxG4_jpkZkGEqAGqCbssabG1nlZZwZAvE0dxn6k4U7r5ytEwfh9bGS9t1JmbLCjAC_–J2kdPVekF1L77UpcOIGg0y4poGFwWBln-hMMHo-CNBIgE6hiZYdfaX0U7i6B.cloud: created=02:23:23PM, exception=IgnoredFileLocalAccessException(code FS109 - Cannot write to filesystem. Illegal character in MY8NgEo4TOsl_PR41DtX3BkaBPeUXPC8HhZeIsjjSRJvEU5UxkciQu_klxA4ERlxntM9z8Q1O4s-idBbUhvnLHkcVqE_MlEe4CyBcveLkiLRkMUwT7mKBG9Ad5yfO1n1dZq1EJaKbKz4nxG4_jpkZkGEqAGqCbssabG1nlZZwZAvE0dxn6k4U7r5ytEwfh9bGS9t1JmbLCjAC_–J2kdPVekF1L77UpcOIGg0y4poGFwWBln-hMMHo-CNBIgE6hiZYdfaX0U7i6B.cloud caused by unicode(Illegal characters))

Hi @mbarre2004,
You can always send me a direct message by clicking on my name and selecting “Message”.

For the items that are hitting this, is this in an Encryptor folder that you have expanded outside of odrive/Encryptor?

No, not that I am aware of. In fact, I would not know how to open up an encrypted folder outside of odrive/Encryptor, if I wanted to.

Hi @mbarre2004,
Are you able to direct message me the “current_odrive_status.txt” file?

I tried, and got the message “Sorry, that file is too big (maximum size is 4096kb)…”

Ahh, okay, no problem. Instead, can you upload the file using odrive and then get a share link to it and direct message me that link?

Done. Done. Done. Done. (20 character minimum, eh?)

Hi @mbarre2004,
Thanks. I took a look.

These do look like Encryptor files that are sitting in the root of your Amazon Drive. The issue is that these files exceed Window’s maximum file length, so they are not being written to your local file system and that is why they are being shown in “not allowed”.

I know you are using Encryptor, but I think you are targeting subfolders within Amazon Drive, and not the root of Amazon Drive. Is that correct?

What may be happening here is that these are encrypted files that you deleted a while ago and Amazon Drive is listing them as orphans after it goes through its auto-trashing routine (Amazon puts “orphaned” files into the root of the drive).

A while ago we made some adjustments to our trashing routine to try to work around Amazon’s unique folder delete behavior, so you should not be seeing new orphans, but if these files are very old then it could be from before we made those changes.

Do you know how long these files have been in the root of your Amazon Drive?
What do the dates show on these files when you look at them via the Amazon Drive web client?

I searched the encrypted files in Amazon for “my8nge”, which is the beginning of the name of the first file in the report, and got 1 hit: “MY8NgEo4TOsl_PR41DtX3BkaBPeUX…” Amazon shows a date added of 1/19/18 for that file.
Edit: I thought I was searching the files in the encrypted portion of my Amazon drive, because I had clicked into a folder in the encrypted portion, but apparently the search function starts at the root folder, rather that the current folder.
Also, I think you are asking if I should have encrypted files in the root folder. No, I should not. I have an Encryptor folder with some sub-folders, and the files in those sub-folders are supposed to be encrypted. If encrypted files got into the root folder, that sounds like a bug.

Hi @mbarre2004,
Thanks!

Can you answer these questions for me?

  • What Amazon Drive folders you are using Encryptor with? (what are the paths?)
  • Are you able to see these long-named files listed in the root of the Amazon Drive from the Amazon Drive web client? I am assuming you can, but I just want to make sure we are on the same page.
  • Do you know how long those files have been there in the root?

I think my first assumption may be correct in that these files you see in the root of your Amazon Drive are previously deleted items from your Encryptor folders. If it is possible that these files have been there for a long time and you just didn’t notice them until recently, then the likely explanation is that you deleted some folders from Encryptor before we made our adjustments to the Amazon Drive delete routine, and those folder deletes ended up “orphaning” these files. If that is the case then these files can be deleted using the Amazon Drive web client.

  • I’ll answer the first question via DM.
  • Yes, I see wacky long file names in the root folder.
  • It has probably been less than a week since I had only 1 file listed under not allowed, and I think that 1 file had to do with an email message with a strange character in the file name or something like that. ( I have had that kind of problem before in a folder in the same area.)

Hi @mbarre2004,
I’ve followed-up in the direct messages to make it easier to discuss paths and such.