Mysterious unknown files/folders under root Amazon Drive folder

Dear ODrive,

I use ODrive + Amazon unlimited storage. I encrypted the majority of my folders. Recently, their happened something strange.

In the root folder, their started to emerge files, some encrypted, some decrypted. For the record, I did not encrypt the root folder (I think it is also not possible). I tried to decrypt the encrypted files to get an idea where they came from. Unfortunately, non of my keys seem to work on them. The unencrypted files I do know. I have no clew how they popped up there.

Can you help me troubleshoot this problem?

Cheers,

Paul

Hi @tulipit,
Yes this sounds very strange. Can you send a diagnostic from the odrive menu so I can take a look?

For the files you do recognize, is there any relationship between them? For example, are they from the same folders?

hi Tony,

I just sent the diagnostic. Furthermore, the folders of the unencrypted files seem to belong to the same parent folder.

Hi @tulipit,
Can you provide a specific (full) path for one or two of the files? I want to make sure I am looking at the right location.

Hi Tony,

Here is an example:
I have now a folder “Hyves” under Amazon Cloud Drive. I never put this folder here. When I started using ODrive, this folder belongs to the folder “Amazon Cloud Drive/Personal/Timeline/People/Hyves”. At a later point in time, I encrypted the Timeline-folder.

My configuration is that 3 laptops are syncing with ODrive.

When I encrypted the Timeline-folder, I had to manually copy past the contents from the unencrypted folder to the encrypted folder. When this process was done, I remove the original unencrypted folder.

In order to get the original unencrypted files on my pc, I specified the unencrypted Timeline-folder to “Sync Everything - Including Subfolders”. When the blue “ready” icon was there, I started copying everything to the encrypted folder. Later in time, I had a few cases where there were still “.cloud” and “.cloudf” files in the folder I just fully sync.
=> What would happen when you put a “cloud”-file or an “cloudf” file from an unencrypted folder to an encrypted folder? Can it cause ODrive to put some files at the root that it couldn’t copy to the encrypted folder?

Another idea that I was heaving is that the other computers that were syncing the same folders were out of sync. When they tried to sync for example the earlier mentioned folder “Hyves”, they did not know where to put it when another computer deleted it’s parent folder “Timeline”, and put it into the root folder.

Hi @tulipit,
Looking through the code, I can’t see anything that would move items around like that. odrive will only react to remote changes for moving local items around. If a path is not found it should end up in the “not allowed” list.

Unfortunately we can’t view the history of a file like we can with Google Drive, so it is difficult to say where the files came from or how they got there.

For the files you are finding here, if you do a search for them via the Amazon Drive web client, do you find them only in that location, or in other locations too?

Same for the the encrypted-looking files, what do you see when you do a search for that filename in the Amazon Drive web client? Do you find them in another location too?

When you look at https://www.odrive.com/account/myodrive?catid=encryption , does everything check-out? Are there any entries there that could be pointing to an unexpected location?

I just want to add to this discussion that like 2 weeks ago, I was deleting stuff from my ACD and I got a generic error message while deleting items in the trash (it happened quite often, when I tried to delete many items and folders at once).

But that 1 time, I got an error and immediately random files and folder started appearing in the root af ACD, obviously no fault of odrive because I was working in the web interface of ACD. A total of 390MB.

Those were my files, but from random locations in my ACD.

I am posting this to point out that ACD is not without its problems, unfortunately.

1 Like

I appreciate you posting your observations @gigaseven. It sounds like you are hitting all of the odd quirks with Amazon.

I have seen a couple of instances where data suddenly vanished from Amazon Drive (verified on multiple clients including their own web client) and then came back later.

I could see something happening on a delete where the parent node ends up in an inconsistent state, so the files are made children of the “root” by default. No idea if it is actually happening this way, but I have seen stranger things…

I just logged into Amazon Drive via the browser and the Root directory contains folders and files that are supposed to be in other places.

My root directory should have just TWO folders.

Why is this happening? Please help me restore my organization.

I have just sent in my diagnostics.

Thanks!
Frank

Hi @frankamoros,
You are the 3rd person now to see this type of behavior (see above). It was never reported previously and odrive hasn’t changed anything that would alter our own functionality with Amazon Drive, so I am thinking that this could be something odd happening with Amazon Drive, directly.

Can you supply a screenshot of what you see in the root of the Amazon Drive folder on the desktop client, and what you see in the root of the odrive folder on the Amazon Drive web client? I would like to compare, especially if the files/folders on the desktop client are cloud files and folders.

For the items now located in root, do you know where they were previously? Are they still in that location too?

Hi Tony,

Attached are the 2 screenshots.

There way too many folders and files now in the root directory. I don’t know off hand their original location and if they are still there. I would need time to go though this.

Thanks,

Frank

Thanks @frankamoros,
The fact that all of these extra items a cloud files points to a remote-side change that odrive picked up. Still, very odd…

Do you have multiple clients using odrive with this account, or is this the only one?

Can you also send a diagnostic from the odrive menu?

What does this mean?
" The fact that all of these extra items a cloud files points to a remote-side change that odrive picked up. Still, very odd… "

I have Odrive installed on my MacBook Air and my MacMini. Both computers are connected to Amazon Drive.

I have just sent diagnostics from both the MacBook and MacMini.

Thanks for helping me fix this.

Hi @frankamoros,
I meant that it looks like the changes originated in the cloud somehow, instead of changes that were triggered on a local machine. If it was on a local machine I would expect one of the machines to have these files as local files, rather than cloud files, but both machines show these files/folders in the root as cloud files (.cloud/.cloudf).

I was trying to find some correlation, but it is difficult since I don’t have context. The diagnostics don’t show any signs of how those files got there.

Once you are able to take a look at the content of some of these items, maybe you can determine if there is a correlation between them and if there were any actions taken on these files/folder recently. Given @gigaseven’s observations above, I am wondering if these items were previously deleted, at some point, and Amazon ended up placing them in the root.

Hi,

I’ve been experiencing a similar issue. Random files/folders appearing at the top level. I don’t ever sync to the top level, only in a couple of top level folders. Its been baffling me for a few days.

I have been researching this a bit and it sounds like this is how Amazon may treat “orphaned” objects, which are files/folders that exist in your account, but are not tied to a parent folder (no"parents" defined within the object’s metadata). When a parent isn’t defined it will place the objects into the root. This is unconfirmed, but makes sense.

Orphaning is generally found in sharing situations, as you would find in Google Drive, but Amazon Drive doesn’t offer this type of functionality, so I don’t know why a particular object would become orphaned in AD. Deletes, moves, or a restores from trash are likely candidates.

Perhaps Amazon is running through an orphan clean-up routine in recent days, which is why these files are suddenly showing up?

For those seeing this, it will help to understand the origin of the files. Were they previous deletes? Were they recently modified? Moved? etc…

Tony, It’s way too many files to check individually but I checked one file and it’s on my Hard Drive already in a specific location.

Can I just delete these files or will it delete the original files too?

Hi Tony,

Thanks for putting your thoughts on paper about how this possibly could be happening. When I have the time, I will make a script that will alert me when new files are added to my root. @frankamoros asks a relevant question whether or not the files can be deleted; I guess we don’t know this for now. We deal with copies, but if we apply an action on a copy, will it also be applied on the original? We need to figure this out.

Cheers, Paul

Hi @frankamoros and @tulipit,
Thanks for the follow-up. I have a few questions regarding the duplicates.

  • Are you able to provide a couple of examples for a file that you see in two locations? (provide full paths for both locations)
  • Are both of these locations within odrive’s view? If so, can you also send a diagnostic so I can take a look?

Hi Tony,

In the search where encrypted files in the odrive-root-folder derived from, I stumbled upon a few files that could not be synced. One of these files:

./odrive/Amazon\ Cloud\ Drive/Personal/Learnings/Study/MaSO8jn3xKyroC8XcOpBbdmANJkMDcGDMQ319iqBD4HtcBwZokjo3i0=/MSc2g63x4btdwCw4SeuC2b–PmQUo32ekzvyt5GtfK1gyF6ldIcY-7rMVfgvhKAFRmy_mDtO1woj/MQ65Kz0ubYzT4dhcYSVHK4yWmMNN7G-C8uuJkyN7ZJu6Z6ND_vKAJbw=/MU8EqyWEmV6V_1d8S61JdZVk5rumuNDe_R3jq87ca2t52SdNaFXTWQdBrg5XUlhZHee0NXo1c0Wa/Mfom91oQyBSC6LuunBy-Cyh6Tkw-9x4YQNYsf7OlW_EblPbGSF0rBWOi5HxqnDO9NIbVDnfFWYKV/MSUozvAPmti2jEkES62c79RE-BBshy9vJQugPcEPYpZW5dKgh4XPvCU=/MRPyilKk5Ulelyxzj6PLpCU2ubc2yu4wGSlj2NJPG9B65hT9mu_BmIs=/McCJ5AZc84jYH5RF2xPxGlcDJlac8qcerV3vgb5BwmWKu0mpNCi7GqM=/MeI9ueiUuZQUni4kW92sgzlz7WcOjobqxhSY1VXJgByAEII76Nlf-ik=/MeEyniUy39QLE40mE-53Qf_getivotmP74-Ucq2HvRnOPih7uAgV87k=/MSRmNL_ESyz8La8tApUDX8NW7i6wFvDAcOXu-N2BIuTl4RiadBuc5Es=/MSS9zVriKtQAQCkv_j0cLfQcauuRRUr4shQAnWg3P0RDQLsSv4iLUvo=/MQk3wQHGFLwSvxRDqZHDNYqv7URMavs-iqwbAybCc3VvXgq5iRoXQrg=/MVY50oLUw-dbc6sdxa0LxGO4QOUK4AiiyB5-TcnRqDuu_Ht6mep1wOI=/MeVKaBhy77MyFNJo7_Wspi_vncRJZdCPMMNtASnzVNEqNaw_-3O4tlM=.cloudf

Odrive gives the following messages: (1) “Can’t sync . Error updating the folder. Unexpected” or (2) “Can’t sync . Unexpected”. These errors are not informative unfortunately. Additionally, the log doesn’t show anything.

Maybe a file-path length issue?
One thing that I noticed was that all folder on the same level couldn’t be synced. It could be that the file-path is too long. I couldn’t find the maximum path-length of MacOS or Amazon Drive. I did found a maximum size of folder- and file name.

To be continued.

— Update
I just scanned all my encrypted files for duplicates with encrypted files that I have in my root. No matches found