Linux CLI not showing all files

I am using a PI 3 running Rasbian Jessie. I have a large dataset ~2TB that is synced to my PI. Recently I noticed that not all the *.cloud files are not being synced to the PI. Is this a known bug? I have restarted and tried to refresh multiple times. I’ve even unmounted and remounted.

Hi @jedhassell,
Are you able to sync existing files and upload new ones?
Is there any thing of note about the files that are not showing up?

What does the “status” command show?

1 Like

I am not sure about syncing new local files. I just use this as a read-only backup. Let me know if you want me to test that though. There’s nothing particularly different about any of the files.

The .cloud files that is does show are able to sync just fine.

status output:

odrive Make Cloud Storage THE WAY IT SHOULD BE.

isActivated: True                                               hasSession: True
email: jed*******                              accountType: CloudDrive
syncEnabled: True                                                version: prod 1
placeholderThreshold: neverDownload                   autoUnsyncThreshold: never
downloadThrottlingThreshold: unlimited         uploadThrottlingThreshold: normal
autoTrashThreshold: never                                              Mounts: 1
xlThreshold: never                                                    Backups: 0

Sync Requests: 0
Background Requests: 0
Uploads: 0
Downloads: 0
Trash: 11
Waiting: 0
Not Allowed: 0

Hi @jedhassell,
When you get a chance, can you run an experiment to see if our are able to list and download new files that are placed on the remote? I just want to make sure that new stuff is showing up, but you are seeing issues with specific items (rather than it all not working).

If we can verify that basic functionality seems to be working, we can try to focus on the specific items that are not showing up, and why.

This also reminds me that we need to release a new version for the Pi. I’ll look into that this coming week.

1 Like

Hi Tony,
Thanks for your help on this. I’ve laid out a few test cases below and added as much information as I have been able to uncover. Please let me know if there’s any other cases you would like to see.

Test cases:

  • Created a new file on the PI.

    • Pass - Shows up on Amazon Drive
  • Create a file on Amazon drive.

    • Pass - Shows up on PI when I refresh the folder
  • Refresh folder on PI

    • Fail - Not all folders are showing up in directory. It seems that all the files are showing up, just not some of the folders. The one folder that is synced properly has all of its files synced properly. It is only one level deep.
  • Delete file on Amazon Drive

    • Pass - deletes are syncing to PI

Also, I am seeing these error messages when I run refresh:

odrive refresh . 

tput: /tmp/_MEIECT9t9/ no version information available (required by tput)
tput: /tmp/_MEIECT9t9/ no version information available (required by tput)
tput: /tmp/_MEIECT9t9/ no version information available (required by tput)

Thanks @jedhassell,
I haven’t looked at the RPi/ARMv6 version of the agent in a while. I’ll try to carve out some time next week to get a newer build for it and do some testing on the Pi3 to see if I can reproduce any of this behavior.

The tput error you are seeing isn’t something I’ve ever seen.

For the folders that are not showing up:
Do they have any special characters in them?
Do you see these folders listed on other clients (odrive desktop client, odrive web client)?
Are these folders within a very large listing of items (over 100 items in the parent folder)?

1 Like

Thanks @Tony,
Below are the answers to your questions.

Do they have any special characters in them?
They do not have any special characters.

Do you see these folders listed on other clients (odrive desktop client, odrive web client)?
Yes, they show up on the Mac odrive client.

Are these folders within a very large listing of items (over 100 items in the parent folder)?
The parent object has 93 items in it. Do you think shrinking this would help?

Hi @jedhassell,
I haven’t forgotten about you. I’m waiting on a new pi build that I can give you to try out.

The amount of items shouldn’t matter, but I was just curious about it. In this particular case, how many items are showing vs how many are supposed to be there?

1 Like

Thanks for the update @Tony,

All of the 85 files are showing up but only 1 of 6 subfolders are showing up.

Hi @jedhassell,
Here is a new version of the agent.

I tested this on a Raspberry Pi 3 with Raspbian Jessie on it and went through many large folders with 500-1000 items in them:

1 Like

Hi @Tony,

I’m still having the same issues with the new version.

Hi @jedhassell,
This is definitely strange.

Let’s try a different approach. Can you try the following steps?

  • Move the local folder that is having issues to another location, outside of odrive’s view.
  • Refresh the parent folder to pick up the delete (it should show up in the trash now)
  • You can trigger a single trash restore by just creating the .cloudf file where the trashed object was. So in this case, create an empty .cloudf file with the folder name (ex: touch foldername.cloudf)
  • Refresh the parent folder again
  • Sync the new placeholder you created to expand the folder.

Does this new folder now show all of the items, or is it still missing the same folders?

If it now has the items in it, you can move the objects inside the original folder from the first step back into this new folder and refresh. odrive should scan through the content and determine what is in sync and what isn’t.

If it is still missing those folders, can you try renaming one of them on the cloud to a very simple name (the single letter a for example), refresh the parent and see if the folder now shows up?

I’m mounting to the folder that is having issues so it is the root folder on the pi. I’ll play around with a few things to see if I can it to act different. When I manually add a .cloudf file for a subfolder and try to sync it, it just says file does not exist.

Hi @Tony,

I mounted the root directory and am only syncing the subfolders I am concerned with. This seems to be working. It seems there is an issue when I mount to a subfolder below the root.

Hi @jedhassell,
Thanks for the update. I’ll have to test this.

This is when mounting odrive on a subfolder in Amazon Drive?
If you create a second mount, as a test, against this subfolder again, so you see the same behavior?

Hi @Tony,
I am seeing the same behavior with missing folders.

Hi @jedhassell,
Thanks for trying. I am still unable to reproduce your issue. I am going to send you a direct message for some additional information.