Linking pCloud option

hi. I cannot find the linking option for pCloud. how to link it?

Hi @bmihelic,

You can connect to pCloud by using WebDAV. Go to and sign in if you aren’t already. Click on the “+ Link Storage” button at the bottom of your list of linked storage accounts. When the link picker comes up, select the WebDAV option.

In the SERVER field, be sure to enter:

The USERNAME and PASSWORD fields correspond to your pCloud account’s credentials.

I just tried it out and I’m able to see my pCloud files and upload/download successfully. Let us know if this doesn’t work for you.


Thanx for your answer, Jeff.

I followed your instruction and it looked like it successfully linked, but the syncing of my pCloud is constantly failing. The odrive message says:

Unable to sync pCloud-bmihelic.cloudf.
Unexpected error. Please try again later.

Is there any solution?


Hi Blaz,

Hmmm, sorry to hear that it’s not working for you. I’m not sure what’s going on there. Can you try out a few things?

  1. Can you use our webclient to see and download your files? Go to while you’re signed in and click into your link folder. Then browse around and see if you can download a file.
  2. Now go back to your desktop sync app. Can you trigger the condition and then go to the odrive app tray menu and select the “Send Diagnostics” option? Let us know when you’ve done this so we can keep an eye out for it.
  3. Also, is there anything different or special about the file you’re having problems with? I’m using a brand new free account with several folders and new files that I just uploaded. Everything seems okay… plus I can see all of the original sample files and folders they create for new accounts. Is this file a plain file in one of your own folders (not a shared folder and not in the Crypto Folder)?


Hi, Jeff,

I successfully downloaded files from the odrive webclient, but odrive still doesn’t sync the pCloud folder on may laptop. Few minutes ago I have sent diagnostics as you suggested. I do not have problems with a specific file but with the whole pCloud cloud folder.



Okay, thanks… I think I’ve narrowed down the issue to a strange issue we’ve seen with connecting to certain services over WebDAV when the timezone of the computer that is running the desktop sync app is ahead of GMT (e.g. if you are in GMT + 5, you would see the problem, but if you are on GMT - 8, you would not). I tested setting my timezone ahead of GMT to GMT + 1, restarted my odrive client, and tried to sync the pCloud folder and ran into the same issue you did.

We’ll have to work on finding a fix for this issue.


P.S. If you want to play around with it / confirm, you can do so by:

  1. Changing your timezone to something like GMT - 8
  2. Exit odrive --> restart odrive
  3. Try to doubleclick on your pCloud folder now.

You’ll see that you can sync things just fine.

It looks like there is another user on the forum hitting the timezone issue, so let’s move this discussion over there since the original question of how to link is answered in this thread.

For anyone running into the follow-up timezone issue, please see this post:


Edit: The timezone issue has been fixed.