Issue with Amazon Drive/Photos counting CR3 files towards storage quota instead of unlimited photo storage

So for several years I’ve been taking advantage of Amazon’s unlimited photo storage to keep backups of my jpegs and RAW files. This worked fine with CR2 files that were uploaded via odrive but CR3 files had not been supported by Amazon up until recently. Now, back in October CR3 support was added to Amazon Photos and supposedly they should now be considered photos and counted towards the unlimited photo storage.

However, I ran into an issue where my CR3 files were not syncing and found the following in odrive’s logs:
Error: code CD_QUOTA_EXCEEDED caused by CloudDriveRequestException(code CD_QUOTA_EXCEEDED - {“logref”:"",“message”:“File size exceeds account allowance.”,“code”:“INSUFFICIENT_STORAGE”} - )

I logged in to Amazon Drive and found that I am in fact out of storage because the CR3s are being counted towards my non-photo storage quota. I have a hunch as to what’s going on but am not sure what my options are.

From what I can tell, there’s a grey area between Amazon Drive/Photos where they share the same storage yet they have separate web /desktop/mobile clients. I tried manually uploading a CR3 file via the Amazon Photos web client and it uploaded despite me being out of storage AND it is a viewable image in both Photos and Drive. I then hopped over to the Amazon Drive web client and attempted to upload another CR3 file and received an error stating I’m out of storage. I went ahead and tried uploading an old CR2 file via Drive and that uploaded fine.

This leads me to believe there’s an underlying issue where Amazon Drive still does not recognize CR3 files as images and odrive may be leveraging an Amazon Drive API instead of Amazon Photos. I’ve tried bringing this up to Amazon’s support and haven’t gotten far yet so I thought I’d come here to see if anyone can think of potential workarounds for the time being.

Is there a different way to link my Amazon account that would make it leverage some sort of Amazon Photos API instead of Cloud Drive? I’m gonna go out on a limb and guess “no” but am open to any other ideas as well.

Hi @cldnatrny,
I can look into this.

We are limited to the available API, but maybe there is a specific mimetype we can set when uploading that will prompt Amazon to process CR3s correctly?

Are you able to provide me with some sample CR2 and CR3 files to test with?

Hi @Tony,

Thanks for taking a look. I’ve zipped a CR2 and CR3 file for you to play around with: RAW Files.zip - Google Drive

Hey @Tony,

Have you had a chance to look into this to see if there is a workaround for CR3 files?

Hey @cldnatrny,
My apologies. I meant to hit this and it fell off my radar. Thanks for reminding me.

I’ve started looking into it and adjusting the MIME type isn’t doing the trick. Looking at how uploads are done within the Amazon Photos web interface, they are using an undocumented upload API :frowning: .

I am going to try to play around with it more this week.

No worries, @Tony. I appreciate you taking a look. And I’m definitely not surprised to hear that Amazon’s making things difficult :upside_down_face:

For now I’ve got a workaround which consists of pausing odrive, re-uploading the CR3 files via the Amazon Photos desktop client (web client is super slow and buggy), deleting the old CR3 files from Amazon Cloud Drive, moving the new CR3 files to the same directory as the old, then resuming odrive’s sync.

When I first resumed the sync it initially threw a fit about not being able to lock the paths for the CR3 files, but shortly afterwards the files all dropped off the “Waiting” list and they all appear to be synced up now. I haven’t tried it yet but I’m cautiously optimistic that unsync will work just fine on these as well. I might just have to change my ingest process a little bit for the foreseeable future. (ingest to unsynced folder or temporarily disable sync, upload directly to Amazon Photos, move local files to correct directory or resume sync afterwards)

Hi @cldnatrny,
Thanks for providing those details. It certainly doesn’t sound convenient, but I’m glad it is at least allowing you to move forward.

What is the typical size range for CR3 files? How large can they end up being?

Hi @Tony,
Most of the CR3 files coming out of my camera fall in the 15-30 MB range but I’m not sure there’s really a set cap on size for them.

Thanks @cldnatrny.

I am hoping to have something you can test tomorrow, if you are willing.

Hi @cldnatrny,
Can you give this version a go and see if it allows you to upload CR3 files without counting against your storage?

Hi @cldnatrny,
I just wanted to check-in on this and see if you were able to give the above version a try.

Hey @Tony I am currently on version 7104 on windows and am having issues with uploaded my cr3 files as well. instead of uploading they get moved to the “not allowed” category when I run Odrive.

Hi @tonfaboy,
We can certainly investigate:

Can you please do the following?

  1. Update to the latest version:
  1. See if the error is still reproducible. If so, please send a diagnostic and let me know when it is sent:

@Tony Hey Tony, I updated to the latest version but I am still encountering the same issue. I just sent my diagnostic report now.
Thanks for the help.

Hi @tonfaboy,
Amazon is returning a strange error for these. I am not sure if it is because they are cr3 files or because of the path.

A couple of things to try:
1 - Since you recently successfully uploaded files to E:/PHOTO/2021/MEM 10-24-21/STAR/STAR/ can you copy a cr3 file in there and see if it produces the same error?

2- If you make a copy of a cr3 file that is not syncing and give it a different extension, like test, does it upload? For example, make a copy of E:/PHOTO/2021/SNAPPR/REHEARSAL DINNER 08-05-22/EMC19690.CR3 rename the .CR3 part to.test and see if it uploads.

Hey Tony, From what I know Amazon should support cr3 files, I tried changing the extension to .test but it made the copy I made unusable so I don’t think thats going to work. So far the other cr3 file I added to the folder that successfully uploaded hasn’t worked yet either.

Hi @tonfaboy,
Testing with my own account, uploads of cr2 and cr3 files work without any issues, which is why I wanted to try to eliminate some variables.

  • Did the file upload when you did this? I just wanted to see if the limitation was on the file type.

Uploading CR2 and CR3 files so that Amazon counts them as photos instead of regular data files required reverse engineering the Amazon web client to see how they were uploading. Amazon has pretty much abandoned their API, so we’ve had to hack a lot of functionality in that has either broken in their API, over time, or never existed.

It may be that the method we are using for CR2 and CR3 files is not available for your account or region, which is why these are being rejected.

  • Can you tell me where you are located?

Hey I just checked and the .test file did upload successfully. and I am located in Chicago IL in the US.

Hi @tonfaboy,
After doing some testing today, it seems like Amazon may have changed their logic somewhere to recognize CR3 files that are uploaded via the standard method. With that in mind, we shouldn’t need to alternate method anymore.

Here is a new build that should allow your uploads to go through.

Give it a shot and let me know how it goes.

To install:

  1. Exit odrive
  2. Download 7184 from the link above.
    3 Install

Hey Tony, updating from 7182 to 7184 worked! thank you for all of you help!

1 Like