I would like to sync local drive with AWS S3

launch Odrive from the start button (I run Win7). NExt from the systray (where your clock is in the task bar) look for the Odrive icon. If it is there, then all is fine and go to the next step.

From your internet browser, go to odrive.com. If all works like it does here with me, you will be routed to your account/myodrive/. From there you’ll see the +Get more links. Click on that text and a popup will show several option. Among your options you will find Amazon S3. Click that S3 icon and fill out your S3 account credentials.

That should be it. I don’t have S3, so can’t help you with further instructions from that point on. Good luck :slight_smile:


@Polar has it correct. If those steps are not working for you, can you please give some additional details on where it is failing? Screenshots may also help to understand the issue.

Thanks and thanks for the assist @Polar!

Tony and Polar thanks for your help
I did get over those steps but I am now facing another problem
I am attempting to sync with an S3 bucket on AWS and after setting everything, nothing works:
Attempting to watch the files using odrive.com I get: “Cannot browse ShimonDekel. Please check your network connection or manage your proxy settings”
Using other interfaces to S3 I see no files
Looking at the service I get the only 2 folders I put in the odrive directory as not allowed (2)

Hi @shimond,
Apologies for the late reply here. This one got lost in the shuffle. Are you still seeing this issue? If so we may need to do some experimentation to understand where things are not working.

Hi there.

I’m having the same problem accessing my AWS S3 bucket via odrive. I was able to set it up okay the other day but now I am getting the “Please check your network connection or manage your proxy settings” message. I still have three days left on the premium trial.

Any thoughts?


Hi @r.harries

So the link was working properly at first and then stopped? Are you able to access it via the odrive webclient? https://www.odrive.com

Can you send a diagnostic from the odrive tray menu?


That’s right. It worked on my Windows and Mac laptops when first set up, then stopped.

I’ve sent the diagnostic from my Windows laptop.

Thanks for looking into this.

Best regards,


Hi Richard,
It looks like the DNS address for that bucket can’t be resolved, for some reason. odrive is trying to connect to it, but no IP is being returned for the address.

Can you verify that the name is correct?

Yes the name is correct. I unlinked it and set up the link again. I also linked to my other two AWS buckets. All three links were set up okay but only one of them (govnum) does not return the same error message. However, when I go into the folder it does’t show any of the files. (There are ten backup files in the bucket.)

I’ve re-sent the diagnostics.


Thanks Richard. I see the issue and am discussing it now with the team.

1 Like

Thanks @Tony. I really appreciate the prompt support.


Can you try unlinking the s3 connections and then re-linking them? We found that Amazon returns a region designation that was not accounted for, but it may be somewhat random. Re-linking could provide the other designation, instead.

In any case we have implemented a fix and it will be out in the next release.

No luck with re-linking I’m afraid. I look forward to the next update. Thanks for developing such a great product!

Can you try unlinking and relinking one more time? We pushed our fix, but it is a difficult one to verify in the lab.


Sorry @Tony, still no luck. My buckets are hosted in Ireland. Perhaps there are some permissions I need to set through the AWS Management Console?

Can you send along another diagnostic from the odrive tray menu? Also, can you unlink and relink one more time from the odrive web client then try to browse that link (which should produce an error)? When you do, can you post the time (as close as possible) of when you did that? I want to see if there are any logs I can look at.

Also, can you tell me if you using s3 optimized or “/” delimited at the link setting?


Okay. Done. Sent diagnostic. Tried tp browse at 10:11 GMT+01.

I didn’t understand about s3 optimised vs “/”. Can you explain?

Aha! I worked out what you meant by “/” delimited. Tried it. It works!

Both ways should work now, if you want to use the “optimized” way.


Fantastic! Thanks @Tony. A really great service!

1 Like