How can I troubleshoot the odrive.exe app itself?

windows

#1

Some time ago (I’m not sure how long) oDrive stopped synchronizing files on a machine I have running Windows Server 2016. When I logon to the machine, the oDrive icon is no longer appearing in the system tray, and when I try to manually launch oDrive, it never shows up in the system tray (or synchronizes files). I’ve tried uninstalling and reinstalling multiple times, but I just can’t get oDrive to run any more. What can I do to troubleshoot this issue?


#2

Hi @michael5,
Can you try running a couple commands from the command prompt (do not run within a powershell session)?

This first command will run the odrive launcher. This should launch the main program in your user home folder.
powershell -command "&{& \"$env:programfiles\odrive\odrive.exe\" \"-v\" 2>&1 | echo;}"

Please copy and paste the output here.

The next command will run the main app manually. Run this if odrive does not launch after running command 1):
powershell -command "&{$bin=$(ls -Dir \"$HOME\.odrive\bin\" | sort Name -desc | select -f 1).FullName; Start-Process -NoNewWindow \"$($bin)\odriveapp.exe\";}"

Please copy and paste the output here.


#3

The first command resulted in the following output, but as soon as I moved my mouse over the system tray icon it disappeared (and no items are synchronizing):

Starting launcher with verbose output...
No product argument was passed in. Attempting to find product.conf...
Using path C:\PROGRA~1\odrive\product.conf...
Using C:\Users\Administrator.HOSTEDPORTAL\.odrive as the installed folder path...
Attempting to mark the installed folder path as hidden...
Writing the product.conf file at C:\Users\Administrator.HOSTEDPORTAL\.odrive...
Reading the version number from the version file...
Attempting to read systemAlertRoom from config...
Setting up diagnostics for buildNo: 6284, productName: prod, systemAlertRoom: 1358891
Creating launcher object...
Checking if another odrive process is running again to reduce the chances of a race condition...
Launching...
Launch succeeded!

The second command didn’t really output anything, though it entered the following text in a new line (ready to press Enter):
C:\Users\Administrator.HOSTEDPORTAL>C:\Users\ADMINI~1.HOS\ODRIVE~1\bin\6284\qml

And pressing Enter at this stage does nothing. I tried to find a directory at the path above, but the bin folder doesn’t exist. (The system tray icon again appeared for a second and then closed out again.)


#4

Hi @michael5,
It seems like the odrive app is running in these cases, although the tray icon is closing, for some reason.

To confirm, can you try using the CLI to check the status of odrive, once you have launched it?


#5

Er, do you have Windows instructions?


#6

To be clear, it isn’t just that the system tray icon is closing. Nothing synchronizes, and I cannot select “Synchronize” from the context menu in Explorer (it doesn’t appear)…


#7

Hi @michael5,
There are windows instructions below the MacOS instructions.

Even though you can’t see the context menu or the tray menu, the results from your previous test show that the odrive process seems to be running. Running the CLI status commands may give us some insight into what is working and what isn’t.


#8

:slight_smile: Oh; I had to expand your response…

But - I think I may have found a clue. I uninstalled oDrive a day or so ago, and my computer rebooted at least once since then. Before reinstalling this time I turned off my VPN, and this time everything worked perfectly. BUT, if I turn my VPN back on, right clicking on the system tray icon doesn’t do anything. Turn the VPN back off, and I can right click on the system tray icon. It’s highly reproducible, using Express VPN.

The problem is that the entire purpose of oDrive on this machine is to automatically sync content through the VPN. So I HAVE to get this working for oDrive to be of any use.


#9

Hi @michael5,
Are you using the built-in Windows VPN client for this?

What may be happening is that all routing is going through the VPN interface, when enabled. The odrive Explorer extension talks to the odrive app via a local network port and VPN must be interfering with that.