High used storage but no files responsible OSX

I recently started using onedrive to unload from files from amazon cloud -

Since doing this I have noticed that the ‘other’ files in the OSX system information is really really big.

I have 340GB hdd, acording to omnidisksweeper it only finds about 156GB - where could the rest possibly be?
the ‘other’ in the storage info is about 200GB - so approx 184GB is unaccounted for

has this happened to anyone else?

Hi @alex,
Do you happen to use Time Machine for backup? I have seen cases where Time Machine’s local snapshots start taking up lots of space. Take a look at this post for more information: Drive space not recovered after unsync on Mac

What is reported when you run this command from a terminal window on your Mac?
df -h

I also found this post, which goes over several potential possibilities for this. It also notes that you may need to run Omnidisksweeper with elevated privileges (sudo) to make sure it can look at the entire disk: https://www.reddit.com/r/apple/comments/3q53dk/100_gb_of_other_on_macbook_pro/cwc4rxf/

this is what it shows - @Tony

I ran omnisweeper with the sudo command and it didnt really pick up much extra

I dont use timemachine

Hi @alex,
You can also use this command to see if you can narrow down what subfolder the space is in:
sudo du -hs /System/Volumes/Data/*

If the numbers do not add up to the total that was shown from df, you may have some sort of disk allocation/accounting problem that may be fixed using Disk Utility, as mentioned in the post I listed above.

With regards to odrive:

  • odrive only stores its files in the odrive folders, so that would be the only place to look to see if this is anything odrive-related.
  • We have a new feature where the odrive placeholders can report size, but actually not use any space on disk (sparse files). This can show up in certain reports and information, but the command that you already ran above will only show actual disk space taken up. For example, my Mac shows 4TB of “Documents” on my drive, which are really placeholder files. The actual space taken up on the drive (which is only a total of 120GB and couldn’t possibly hold 4TB) is 0 bytes by these files.

Thanks @Tony
I ran disk utility and it seemed to find lots of errors so I think I just need to fresh install eveything from a timemachine backup
things like ino_ext_type_dstream -
seems like others have had this issue -

THanks for your help!

No problem @alex! Sorry to hear that your disk is having some issues and I hope you are able to get it restored quickly.