Got a half-synched folder

I was synching a folder down from Amazon Cloud Drive (it was completely unsynched), when I had to reboot my Pc (Windows 10). When I restarted odrive I was expecting the sync to continue, but it didn’t (white icon). I tried right-click-sync on the folder but that doesn’t restart it either. The icon is showing a tick which I think means it is completely synched. The files were split into 100MB chunks on upload. I even tried right-click-sync on a set of selected files but that doesn’t seem to work either, so I have to do each one individually. I can’t do that that to the partially synched ones though as that only allows me to unsynch them. Version is prod 5689

Download operations will not restart automatically if interrupted. Uploads will, however.

When you right-click->sync the folder, is the slider set all the way to the right (“everything”)?

I missed the action box which was sitting in the taskbar as it didn’t get focus. I’ve now seen it and it is now synching the rest. There are still a lot of the “partial” files in the directory from before the reboot. Will these clear themselves up?

If odrive exits unexpectedly, partial “staging” files can be left around. Right now odrive will not go back and clean them up.

If you want, you can run a script from the a command prompt (cmd) to clean up these files, if you feel you might have some around. Make sure that odrive is not actively downloading anything when running this, so you don’t potentially wipe out a currently downloading temp file.

powershell -Command "&{gci \"$HOME\odrive\" -r -force -file -filter \".~*-*-*-*-*\" | ?{$_.mode -match \"h\"} | rm -force;}"

Thanks for the script - it may come in useful if it happens again. This time I actually unsynched the directory and started the download again.

1 Like