FTP connection failed | Cannot browse MyCloud. Please check network connection or manage your proxy settings

ftp
sync-to-odrive

#1

I’m trying to connect my WD MyCloud. I Have forwarded all ports on my router to access the ftp server external. When I go to the ftp server in my browser of filezilla it works just fine. But when I try to connect it to odrive with the ftp option I get the error “Cannot browse MyCloud. Please check network connection or manage your proxy settings” (this happens on desktop too).

(Tried multiple other ftp servers but none of them worked because of this error)

If you send me a PM I will provide you a test account

How can I get this to work?


#2

Hi @cas.sprenger,
For FTP links, you won’t be able to browse from the odrive web client. It is an unfortunately limitation of the platform. You should be able to browse via the desktop client, however.

Have you tried via SFTP? There is a post here with some information: Can I link WD My Cloud?


#3

Hi @Tony, Haven’t tried SFTP yet but wil do it tomorrow. FTP did also not work on the desktop client, got the same error. Should I link the host (my external ip) as 123.456.78.90 or as ftp://123.456.78.90?


#4

Hi @Tony,

I tried ftp with these settings but I can’t get it to work.

I also tried to connect with SFTP but I can’t get it to work as well.
Is it possible to send you the username and password so you can try it?


#5

Hi @Tony , I got it to work ish.

I can enter the root of the ftp wit the admin account but also with subaccounts, but all the subdirectories don’t work. Every time I click one of them I get one of the following errors:

  • Unable to connect to the FTP server: too many simultaneous connections.
  • Please check your network connection or manage your proxy settings.
  • This file doesn’t exist.

Can you please help me to get this to work?


#6

Hi @cas.sprenger,
Are you able to spare more than 1 concurrent connection? That may be causing problems with background operations mixing with foreground operations, which is why you would see the first error.

The other two are strange. Can you reproduce those and submit a diagnostic from the odrive menu?


#7

Hi @Tony, it should be possible to have 10 concurrent connections on the WD MyCloud if I read it correctly in the MyCloud ftp settings.

I will try to reproduce and submit a diagnostic this weekend. If you want to reproduce it yourself earlier or just test the connections, I have send you some login details in a PM.


#8

Hi @cas.sprenger,
I was able to link over standard FTP using the credentials you gave me, and I was able to browse, create a file, and edit it. This was setup with ‘FTP’ as the protocol and 2 concurrent connections.

If yours fails with that configuration with the same account, can you send a diagnostic after the failure?


#9

Hi @Tony,
I tried to set it up the way you did but unfortunatly it didn’t work and got the “Please check your network connection or manage your proxy settings” error again. Tried it with the checkbox for ssl checked and unchecked but it didn’t make a diffrence.

I have send a diagnostic from the odrive desktop menu after I got the error message.


#10

Hi @Tony,

I was able to connect it with the sftp (ssh) option without getting any errors.
Thank your for all the help, I hope this will work as I was hoping for.

Keep up the good work!

Kind regards
Cas Sprenger


#11

Thanks for the update @cas.sprenger.
I’ve found that SFTp tends to be a better option, if available, since it is more ‘standardized’ than FTP. Glad you got it working!