Cant Unsync - No Permission

Some folders can unsync - some cannot - i have researched and cleared recycle bin and rebooted multiple times and i still cannot unsync folders due to no permission error…

what can i do - thank you!

Hi @bjmjpl,
Can you do the following for me?

  1. Tell me what operating system you are running
  2. Provide a screenshot of the error
  3. Click on “send diagnostics” in the odrive tray menu.


win 8.1 updated…

really jamming me up…happening with 2 other folders but 3 worked fine…just getting started…

diag sent

thank you!!

This generally indicates that the OS is not letting us remove the directory, for some reason. Let’s see if anything is actually holding on to it:
Download this utility (no installation needed), just unzip and run:

Once you’ve got it running hit ctrl+f and type in the directory name (or partial name) that is reporting no permission.

What comes up?

using the exact name of the folder - 0 matches found on one…

and 0 matches found on the other one…

the third one is named “a” so thats a ton…

thank you

Thanks. Just in case, can you try a partial string on the folder in the image. 091713 should be unique enough to search on.

0 matches…

anything else i should be doing?

Okay, let’s try some other things.

Click on “Pause Sync” (it might also say “Stop Sync” if something is in process) in the odrive tray menu. This will stop the syncing of any new changes. Once that is done, try renaming one of the folders that is showing the issue (just add a -1 to the end). Does it allow the rename? If so, go ahead and rename it back.

Are all of the files/directories inside the problem directory already unsynced? If not, try unsyncing them to see if you can get them all to become placeholder files. You should be able to multi-select -> unsync. If a directory inside fails, drill into it until we find the one thing that is causing the hangup. If everything is unsynced inside then try unsyncing the problem directory again. If it still is not working we will move on to the next test.

Next, let’s take a look at the following things. We’ll be using powershell commands for these so open up a command prompt and then copy and paste the following commands in. Please take a screenshot or copy the output into this thread:
powershell -command "& {$owners = @{}; gwmi win32_process |% {$owners[$_.handle] = $_.getowner().user}; get-process odriveapp | select name,cpu,pm,vm,processname,Id,@{l='Owner';e={$owners[$]}}}"

The above command will print out a few details on odriveapp, including the owner.

powershell -command "& {Get-Acl ""$env:userprofile\odrive\Linked_Source_Name_Here\Path_of_Directory_Here\"" | Format-List}"

The above command will give us the permissions on the directory in question. Please substitute the path above with your directory path after the \odrive\ part.

ok i can rename it in file explorer and i renamed it back successfully

i am going to reboot because after i try the high level unsync - if i try anything again it says there are files not in sync…

Make sure you do not have any items in the trash. Those will cause that message because the deletes made in that folder are not yet in sync (you have not committed them by emptying the trash).

ok i have cleared the recycle bin on the computer - is that what you mean - there is no trash anywhere else i can find…i have been doing that as i have seen that in the forums so i will check again on the next reboot but i was able to unsync most doing the unsync of deeper folders and at least continue the upload process so ill try to narrow down what is happening and see if i need to do the command line stuff…

thank you

I’m glad things are back on track. I was actually referring to the odrive trash, located in the odrive tray menu, but it sounds like things are sorted. Please let me know if it happens again.


alright i figured out how to work through those above issues and i love it and thats great - now i have uploaded over 8 TBs and im almost done - but now i have been gone for most of june and the same 15 files seem to keep stalling out and its says the ten 10 that are current are 30+% and then it resets the next day back to single digits -

these same files havent uploaded all month and im not sure why -

a few of them are big 50gb+ files - is that the issue?

it also seems when i restart my computer the START OVER FROM BEGGINING why would that be?

thank you!

Most services have a limit on the size of the file that can be uploaded. Amazon Drive’s is 50GB. If you are uploading files larger than that then they will always be rejected at the end. You should use odrive’s IFS feature to get those files up. Take a look at this article for more information:

that is great info - thank you but only one of the files is actually bigger than 50 GB…so im not sure - but its been loopiing again for 5 days…i sent a log 5 days ago…should i split files that are bigger than 40GB?


It really depends on your connection speed, but if you are finding that you are having issues uploading large files you should try using IFS. 40GB is a very big file and I would recommend switching on IFS to upload all of your looping large files. You can turn it off afterwards.


yeah my connection speed is supoerfast 150gb…but ill try the split - interestingly…it just went down to only 7 files left…not sure how or why but hopefully the backups worked…

thank you

The risk of an inter-transfer failure increases with the size. Amazon Cloud Drive is known to have upload issues with large files, as well.

Are you sure you have a 150Gb pipe (18750 MB/sec), or do you mean 150Mb (18.75 MB/sec)?