Can't run odrive zorin os

installed the client on Zorin Os perfectly fine but as soon as I run the agent the terminal stay waiting for some reason.

Capture added

Hi @hcerbello,
That is actually expected. You can run the agent process in the background, if you want, using a command like this:
nohup "$HOME/.odrive-agent/bin/odriveagent">/dev/null&

Otherwise you can leave it running in the foreground and then open up another terminal session window.

In either case, you will then want to use the odrive CLI to interact with the agent.

Awesome! sorry my bad! Im almost done, the folder is created but can’t see the google drive that is linked to my odrive account. Im probably missing something ?


I finally figure out how to sync, all looking good now, thanks so much for your help!
What if I want to put a file inside one of the folders on my google drive, drag and drop will auto sync as i do in mac os ?

Thanks again!

Hi @hcerbello,
The Google Drive account is showing up as a placeholder file (Google Drive.cloudf).

If you want to “expand” this folder (turn it from a placeholder to a real folder), use the sync command on it:
./odrive sync "[path to placeholder file here]"

This will allow you to browse into that folder and see what is inside. Keep in mind that everything will start as placeholder files. This allows you to pick and choose what you want to download.

If there is a particular folder you want to have completely expanded, so that every folder underneath is available you can use the sync command like this:
./odrive sync "[path to placeholder file or folder here]" --recursive --nodownload

If you want to expand AND download all files in the structure, you would remove the nodownload option:
./odrive sync "[path to placeholder file or folder here]" --recursive

The recursive download in this case is serial, but you can use some scripting tricks to facilitate multi-threaded download:

Yes. On linux odrive will automatically pick up the new file within 15 minutes or so. You can tell odrive to refresh the folder immediately by sending it the “refresh” command on that folder. That will cause it to upload immediately:
./odrive refresh "[path to folder]"

Awesome, thanks so much again!

1 Like

Sorry one more question if you don’t mind.
How can I properly setup the path, for some reasone it’s not letting me sync, the terminal keep saying “no such file or directory”


What is the full path you are trying to sync?

/home/hernan/Desktop/Google Drive/Raul Britos

that’s the folder name Im trying to download.


Hi @hcerbello,
I would expect that the path to sync that Google location would be something like:
“$HOME/odrive-agent-mount/Google Drive/Raul Britos”

It may be that there is some confusion/misunderstanding, so definitely let me know what you would like to do and what your expectations are.

Thanks Tony, Im probably doing something wrong, path is ok.

Hi @hcerbello,
Thanks for the screenshot!

Can you ls the Google Drive folder and the Raul Britos folder?

Maybe the Raul Britos folder is still a placeholder? In that case the path would be “$HOME/odrive-agent-mount/Google Drive/Raul Britos.cloudf”

still nothing :confused:
the odrive app is located here .odrive-agent/bin/odrive
Could be that the problem?

ls still the same > no sush file or directory

Hi @hcerbello,
Run the following commands and send another screenshot, please:
ls "$HOME/odrive-agent-mount"
ls "$HOME/odrive-agent-mount/Google Drive"

Hi @hcerbello,

Do you see an item named “Raul Britos” anywhere in the "$HOME/odrive-agent-mount/Google Drive" folder?

What about when you browse to that location from the odrive web client here: odrive | Sign in

What about when you go to ?

Maybe it is in a different Google Drive account? You can link more than one Google Drive account to odrive, if so.

the folder “Raul Britos” is inside Google Drive.

Ohhh! Sorry I wasn’t looking close enough. You need to use the full path to the odrive binary if you aren’t in the folder where it is.

So that is probably:

So the command would be:
$HOME/.odrive-agent/bin/odrive sync "$HOME/odrive-agent-mount/Google Drive/Raul Britos"