Badging of files and folders disappeared

Hi,

I’ve been using odrive for a long time and the badging that indicates the current sync status for file and folders has been working OK with the xplorer2 Ultimate, version 3 (Windows explorer replacement).

Now I upgraded to xplorer2 Ultimate, version 4 and the badges do not show anymore. I restarted the PC and it does not help. If I go back to the previous version of xplorer2 the badges show up again.

Is it something that you could fix? You can download the trial version of xplorer2 Ultimate, v. 4 from here to check what could be done:
https://www.zabkat.com/x2down.htm

Thanks!

Hi @mr108,
We haven’t changed anything in this area, so there must be something that happened in the new version of xplorer2.

We only officially support the extensions within Explorer. We just don’t have the resources available to develop and test for third party Explorer replacements, unfortunately.

You may want to reach out to the xplorer2 team to ask them if they have any ideas.

Do the context menu options still show up? If so, it could also be possible that xplorer2 has added their own overlays and pushed odrive’s out. Windows has a limited number of “slots” for overlays and if new applications are installed that put their overlays in front of others, it can prevent other application overlays from showing up. A little more on that here:

Hi Tony,

Thanks for a quick response.
What I did in the meantime was reinstalling odrive desktop for PC. But when uninstalling it Avast blocked some file and placed it in quarantine - see the screenshot
odrive

Now in that screenshot the details are not visible - very strange! And I checked the Virus Chest and there is NO trace of that file that was supposed to be moved. Something got screwed up!

Was that file part of odrive? Was it necessary for odrive to function properly?

Now that I installed it again the badging of files disappeared completely both from xplorer 2 and even from Windows explorer! And the right-click context menus do not show up at all.

What to do now?

Hi @mr108,
.RBF files are usually part of the uninstall process. I think it is created on the fly by the uninstaller. In this case it is a false positive by avast. It may be that this prevented a complete uninstall and left some items around.

Try disabling avast and then performing a repair install (install again and select repair) and see if that helps. If not, uninstall odrive again and then reinstall and see if the shell extensions show up.

Thanks again,
I reinstalled it and the badging and shell extensions are showing up :slight_smile:
Will have to sort out the xplorer2 issue.

1 Like

Glad to hear you got them back. Thanks for the follow-up @mr108.

Many thanks for that complete information!

1 Like