Amazon Drive sync problems after running out of cloud storage space

My odrive stopped syncing awhile back and I figured it was because I ran out of space on my Amazon Drive account. I have since cleaned up some files and got back to having available space but odrive isn’t syncing anything with Amazon Drive. If I try to sync anything, I get the “unable to sync…please check your network connections or manage your proxy settings”.

I also use odrive to sync with Dropbox and that is working as expected so I don’t believe it to be a networking issue.

Hoping you can see something that I can’t. Thanks.

Hi @wilsonrm,
Can you trigger the error again and then send a diagnostic from the odrive menu?

Triggered the error and sent the report

Thanks.

Hi @wilsonrm,
Can you try sending it again? It did not come through, unfortunately.

Are you using any proxies, firewalls, or endpoint protection software that could be interfering?

Re-sent. No firewalls or proxies. Works fine for Dropbox so I’m assuming it’s an Amazon thing. I ran out of storage but now have free space but I can’t get it to sync.

Hi @wilsonrm,
The diagnostics are still not coming through, so I wonder if something with the app configuration/databases is out of whack and causing some of these issues.

What may be best to try is to reinstall the software, so we have a fresh configuration to work from.

Can you tell me what storage you currently have linked?

The basic method for how we would do this is as follows:

  1. Shutdown odrive
  2. Move the odrive folder to another location. Making a copy of it would be best so we have some redundnacy.
  3. Uninstall odrive
  4. Install odrive and login with the same account you were using before
  5. Close odrive and replace the odrive folder with the folder from step 2
  6. Start odrive

The intent here would be to get a fresh install and then move the local data back into odrive so it can sync and upload what it needs to.

Before attempting this, please let me know you have any questions on the above steps or need more clarification on anything.

Still not able to get Amazon to sync. Dropbox still working fine. Followed the instructions and submitted a report.

Hi @wilsonrm,
Your diagnostics are still not coming through. This seems to indicate that something is interfering with some of the odrive network communication on your system, since both Amazon Drive and our diagnostics calls look to be blocked.

You mentioned previously that you didn’t have any services that could be interfering (endpoint protection, proxy, firewall, etc…), so I’m not sure what could be causing this.

  • Is this your home network?
  • Are you using wireless or a wired connection?
  • Is it possible to connect via a different network (temporarily tether to your phone, for example)?
  • Are there any other systems on your network that utilize odrive? If so, do they have the same issue?

Another thing to try:
If you create a space that points to your Amazon Drive, we can see if you are able to sync via that Space on your Desktop client. You will find the Space under the “Spaces” folder in the root of the odrive folder. https://www.odrive.com/account/myodrive?catid=spaces

After creating the space linked to Amazon Drive, I am able to sync the folders but cannot sync the actual files. This is slightly different than the behavior of the Amazon Drive folder itself. It won’t let me sync the folders at all.

I tethered my MacBook to my phone and got the same behavior. I tried to submit a report while tethered to see if that would go through. I have tried on my home wifi and work’s wifi. I don’t have any other computers to try on.

Are there any networking settings that I can check/change?

Hi @wilsonrm,
Unfortunately the diagnostic still didn’t come through. Interestingly (and frustratingly), all of the endpoints that are not coming through are hosted on Amazon infrastructure. It is as if your system is refusing to allow odrive to access Amazon services, for some reason.

A few things to try:

1 - Are you able to browse and download files from your Spaces and Amazon Drive from the odrive.com web client?

2 - Can you open a terminal on your Mac (type terminal into spotlight search) and then run these commands and let me know what they return? These are all endpoints that seem to not be working properly on your system. I would like to see if they are blocked in the terminal, or if this seems to be isolated to the odrive app.

  • curl https://content-na.drive.amazonaws.com (You should get a message about the resource not existing)
  • curl https://odrive-deploy.s3.amazonaws.com ( You should see an “Access Denied” message)
  • curl https://odrive-diagnostics.s3.amazonaws.com ( You should see an “Access Denied” message)
  • curl https://api.amazon.com ( You should see a “Looking for something?” message)
  • curl https://proxygen.odrive.com (You should see a “503 Service Unavailable” message)

1 - I am able to successfully download files from both Spaces and the original Amazon Drive

2 -
curl https://content-na.drive.amazonaws.com - returns “Resource does not exist”
curl https://odrive-deploy.s3.amazonaws.com - returns “Accessed Denied”
curl https://odrive-diagnostics.s3.amazonaws.com - returns “Accessed Denied”
curl https://api.amazon.com - returns “Looking for something”
curl https://proxygen.odrive.com - returns “503 Service Unavailable”

Thanks @wilsonrm!

This is very strange, indeed.

I’d like to double-check your version of odrive. Can you tell me what the version number is when you look at the odrive menu right above the “Send diagnostics” option?

Let’s also try to run odrive in a special way, to see if it provides any information, in lieu of a diagnostic report.
Can you perform the following steps, please?

  1. Open a terminal session (type “terminal” in Spotlight search):

  2. Run the following command in the terminal session (copy & paste + Enter):

    Command:

    bindir=$(ls -d "$HOME/.odrive/bin/"*/ | tail -1); echo $bindir;"${bindir}odriveapp.app/Contents/MacOS/odrive"

Now try to sync some files in Amazon Drive, and the Space you setup against Amazon Drive. I am hoping that some useful information will be spit out to the terminal that we can use to troubleshoot this. Please copy and paste what it prints out here (if anything) so I can take a look.

prod 6449

Results from terminal command:
/Users/rywilson/.odrive/bin/6449/
2018-10-08 06:23:05.056 odrive[52926:9027863] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) ‘Permission denied’, port = 0xa603, name = ‘com.oxygen.odriveapp.ui.odrive.uiServer’
See /usr/include/servers/bootstrap_defs.h for the error codes.
2018-10-08 06:23:15.961 odrive[52926:9028204] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) ‘Permission denied’, port = 0x1907, name = ‘com.oxygen.odriveapp.uiServer’
See /usr/include/servers/bootstrap_defs.h for the error codes.
Segmentation fault: 11

Still not syncing

Hi @wilsonrm,
My apologies for not saying this before, but can you please exit odrive before running this command? The above command will try to run odrive, but it will fail if odrive is already running.

Exited and launched via terminal. Same behavior for the original Amazon Drive account - won’t let me open unsynced folders. The Space does let me browse unsynced folders, but won’t download the files. This was all done using my hotspot because i’m traveling.

thanks for all your help on this.

this was returned after executing terminal command:
/Users/rywilson/.odrive/bin/6449/

Thanks @wilsonrm!
That indicates it is running. If you try to sync to Amazon Drive, does anything show up in that window?
What about if you try to send a diagnostic?

Just sent a diagnostic report. I can still browse through my unsynced folders, but get this when i try to download the file:

I did test adding new files to the Space i created and it is successfully uploading new files to Amazon Cloud. I can successfully unsync the new file, but when i try to access it i get the error.

Hi @wilsonrm,
Has anything showed up in the terminal window after all of these actions? I was hoping for some clue there, since we are unable to receive your diagnostics.

Nothing shows up in the terminal window after trying to sync files unfortunately